This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 21 replies, has 2 voices.

Last updated by Yvette 2 years, 8 months ago.

Assigned support staff: Yvette.

Author Posts
October 17, 2017 at 8:41 am #1402997

sallyR

Hello,

im using Divi Theme 3.0.82 with WPML 3.8.3. I use Spanish as Primary Language, and English as secondary Language. I have the Problem that if im changing yet some formatting in Spanish Language, like Color, Space etc. that in the English translated Version all formatting is gone!

So if do one change in Primary Version like edit content, color or space, I have to do ALL the formating in the English (Secondary Language) again?

How can this be fixed??

Thx

October 18, 2017 at 8:44 am #1404356

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello.

Please help me make sure that I have completely understood the issue:

I understand that you have a set of translated pages using Divi theme and I suppose the DIVI Builder. When you change attributes of builder elements such as the color, font,...etc, the result in the translated version is that the values of these layout attributes are erased (?) in the translated version.

The result is that the original page shows the changed formatting and the translated page has lost all formatting.

Did I restate the problem correctly?

1. Editor
Please specify if you are using the Translation Editor to create the translations or if you are using the standard WordPress Editor to create "manual" transaltions.

2. Simplified case
2.1 Can you create this same problem with a new page that has only one element?
2.2 Does this problem occur with all types of builder elements or only with a specific type of builder element?

3.Temporary Access to your system
Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Please indicate the simplified test case that I can study.

Thanks

October 18, 2017 at 5:28 pm #1405053

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK. Could you please respond to these questions and provide access to your system?
1. Editor
Please specify if you are using the Translation Editor to create the translations or if you are using the standard WordPress Editor to create "manual" transaltions.

2. Simplified case
2.1 Can you create this same problem with a new page that has only one element?
2.2 Does this problem occur with all types of builder elements or only with a specific type of builder element?

3.Temporary Access to your system
Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Please indicate the simplified test case that I can study.

Thanks again.

October 19, 2017 at 12:16 pm #1405864

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello.

Thank you for the system access. I created a test page with simple content and formatting (e.g. Design attributes set via the pagebuilder element)

Here are my observations:

1. Manual v. Translation Editor
The method that you are using is not "manual". You are using the WPML Translation Editor.
This distinction is important.

2. How to execute changes with the Translation Editor
Please read the following erratas carefully
https://wpml.org/errata/translation-editor-strings-ignored-after-editing-the-translated-post-in-wordpress-native-editor/

https://wpml.org/errata/editing-translated-shortcodes-with-wordpress-native-editor-removes-them-from-wpml-translation-editor/

I believe the behaviour you describe is a manifestation of the first link above.

3. Workflow you are using.
You asked what is the recommended "workflow" to avoid these issues.
3.1 First read the errata carefully
3.2 Do not mix the use of the translation editor with the native WordPress editor.
3.3 Always make sure to fully complete the updates of translations before attempting to make additinal changes.

--OR--

Use only the "MANUAL" method to translate the posts. This means to change the editor setting that you have set here:
WPML -> Trnalsaiton Management -> Multilingual Content Setup -> How to translate posts and pages
Select to use : "Create tanslations manuall".

In this manner, you avoid the string synchronisation issues altogether until a better synchronisation workflow is imposed by the WPML modules (this is due out in the next release of WPML).

October 20, 2017 at 7:47 am #1406738

sallyR

Dear Yvette,

thanks for taking a look, but first of all please if you create in the future test pages in our website I will deeply appreciate if you could put them no index no follow and private, because as you can see the website is already open...

the test pages were anyhow created and it was Pagina de Prueba

second I did what you suggest me and this is the message I get and more important when I want to translate the page it redirect me to the divi theme page... and this doesn't work for me...

It have to be a solution for the translated pages not to loose the content or edition if I made a minimal change in the original language page...

October 20, 2017 at 8:51 am #1406827

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Test page
Sorry about that! I will definitely keep your suggestions in mind for the next time.

2. System Message
The message you are seeing is coming from the Translation management system. It is appearing when it detects a translation "job" open when you are trying to edit the post before closing the existing job.

If you go to WPML -> Translation Management -> Translation Jobs to cancel the job --OR-- update the translated post completely (to close the open job) before attempting to make changes to the original post. This should remove the message.

Once you only use the manual trnaslations, this should not happen anymore. Have you changed the editor setting?

3. Redirection
I use DIVI regularly on my local system and I am not able to replicate this behaviour. I tried to view it on your system but the credentials you provided earlier no longer give me access to the dashboard.

Can you please check the privelges of this account and let me know when I can try again?

KR.

October 22, 2017 at 1:44 pm #1408011

sallyR

Dear Yvette,

Thanks for your answer, I did what you ask me, but I still have the problem... as I told you before, I dont want to make the translation manual, because I put a lot of modules to build the page, that means that I need the editor of wpml to translate each modul, that being said means the manual possibility is not an option.

I created a second test page and everything worked fine, but when I wen to the cookie policy ( the spanish version of course) and add some spaces between each title this happened

the first photo is the original English version

and the second photo you can see in the wpml editor how the edition is lost meaning the size of the title of the cookie policy and the other tittles in compare with the spanish version on the left.

it cannot be that by adding just a few spaces all the formatting of the English page is lost... or??

please send me the secure form so I can send you the new credentials

thanks

October 23, 2017 at 4:05 pm #1409013

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I am sending you the secure form.

Thanks for the specific example.

October 24, 2017 at 9:26 am #1409747

sallyR

<Removed by WPML Support>

October 24, 2017 at 8:00 pm #1410578

sallyR

Hello Yvette,

please see attached updated login Information.

Thanks,
Best Regards
Sally

October 25, 2017 at 10:41 am #1411146

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello.

I cannot see the attachment and I confirm that the details you provided in your last message are no longer working.

We still cannot opena private area on the forum. I am now sending you a private email. Please check your inbox.

October 27, 2017 at 7:40 am #1413734

sallyR

Hello Yvette,

could you already check with the new credentials what I send you ?

Thx
Best Regards
Sally

October 27, 2017 at 5:34 pm #1414394

sallyR

Dear Yvette,

could you already check???

Thx

October 27, 2017 at 6:01 pm #1414418

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes - they work and I am working on this now.

October 29, 2017 at 11:27 am #1414956

sallyR

Hi Yvette,

I just wanted to know if there is any news?
thanks

The topic ‘[Closed] Editing already translated Page formatting gone’ is closed to new replies.