This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by chrisL-34 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 11, 2019 at 1:27 pm #4190125

chrisL-34

I am trying to: Edit a page called FAQ, clicking on "Edit the English Translation". What happens is that instead of getting the auto translator I get the normal "Page translation" tool. This wouldn't bother me so much except for the fact that almost all fields are missing!

The two different sites can be seen here:
hidden link (Swedish)
hidden link (English, WiP)

I expect this: That I would be able to remove the "Page translation" tag from this page and use the automatic translator instead, or at the very least to have the translation tool realize there are more fields than it is displaying.

I believe the Page translation is used because we added the FAQ to a translation queue (the job is 100% completed but can't be removed from the list). But I may be mistaken?

Any help would be greatly appreciated

/Chris

July 12, 2019 at 12:52 am #4193897

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 22, 2019 at 7:13 pm #4260947

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your website and noticed the WPML Translation Editor is properly showing all the text content of your default language FAQ page, it is possible to see all the FAQ page content available for translations, actually you only have two kind of fields translatable: The FAQ page header content and the FAQ text content itself and this is what WPML is reading for translation. In your case it seems you prefer to use the WPML Advanced Translation Editor to translate your content, if it is the case you need to follow these steps:

1 - In your WordPress Dashboard > WPML > Settings > How to translate posts and pages and choose the WPML Advanced Translation Editor as your prefered translation editor.

See: https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

2 - Now click to translate your page and choose to translate it using WPML Translation Editor, instead of the WordPress default page/post editor.

See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

As regarding your translation issue you mentioned in your most recent reply, I would appreciate some more details on how to reproduce it from scracth so I can make a test and understand the cause of it. Thank you for your collaboration and continued patience, have a nice day.

July 30, 2019 at 11:00 am #4307043

chrisL-34

Hi,

For our pages we have selected to translate/copy relevant fields, however it doesn't seem to do so:
hidden link (Company page in Swedish)
hidden link (Translated Company page)

It has been translated using the advanced translator yet nothing shows up?