Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Bobby 1 month, 1 week ago.

Assigned support staff: Bobby.

Author Posts
October 15, 2019 at 8:25 pm #4760389

marijnS-2

Tell us what you are trying to do?
I need an editor to be able to translate a post. I can't get it working. I have added the user as translator. The pencils in the post overview are there but if you click them it shows an overview of a translation que.

Is there any documentation that you are following?
I searched the WPML forum and other websites.

Is there a similar example that we can see?
See screenshots

What is the link to your site?
hidden link

October 16, 2019 at 4:30 am #4761963

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

1. Please go to WPML->Translation Management->Translation Roles-> verify that your editor has access to the specific language pair.

2. Review the icl_translations_status Database table and verify that the "batch_id" field is existing. (screenshot)

October 16, 2019 at 5:39 am #4762161

marijnS-2

Hi Bobby,

Thanks for your support. The editor has access to the specific language pair. See screenshot.

I don't understand where to find the icl_translations_status.

October 16, 2019 at 6:01 pm #4767893

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

The database table wp_icl_translation_status is located within your Database.

If you are not able to locate it I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed I recommend taking FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

October 17, 2019 at 5:13 pm #4776159

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for the access details!

I have reviewed your database and everything is looking as expected.

Accessing the translations with the Editor account worked successfully.

After you click on the "pencil" and taken to the Translation Queue Dashboard, click on Edit (Bewerken) and you will be able to edit the translation.

The editor can also edit the default language successfully.

Please test and let me know your results.

October 17, 2019 at 6:07 pm #4776501

marijnS-2

Hi Bobby,

Why does it need an extra step. If I click edit from the admin user account I directly go into the translation dashboard.

Secondly most fields are not shows and the content of the textfield is not correct. See the difference between the screenshots.

Regards,

Marijn

October 17, 2019 at 11:12 pm #4777523

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

When i review the Translation Jobs on your site it looks like these pages ("BI specialist, Data scientist, etc") have been sent and translated by Avanti Language Services, correct?

They are all in the status of "needs updating" , which i believe is why the editor is being taken to the Translations Queue dashboard.

1. If you create a new page/CPT and then access it with the editor it works as expected

2. If you manually update any of the content such as "Data Scientist " then the editor will be able to access it again as well.

Meaning go into the default language and edit it, add a space or a period->Save and update the content-> then a "Loading circle" will show in your translation and the editor will be able to access it.

As a test try with "Java Developer".

Please review the translations sent to the Translation Service and let me know your results

October 18, 2019 at 6:42 am #4778741

marijnS-2

Yes, Avanti did the total translation of the website, but from now on we want to keep track of all translations. Is there a way to "reset" the status for all pages and posts? It's a huge job to go over all pages...

Thanks for you help so far.

October 18, 2019 at 6:22 pm #4784897

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

I believe you should be able to update their status or even cancel ongoing work from within the "Avanti Language Services system".

Please login to your Avanti system and let me know your results.

October 30, 2019 at 10:02 am #4854319

marijnS-2

Hi Bobby,

Unfortunately it is still not working as it should 🙁 I did a reset on the professional translation status, but still the editor is not able to translate.

Please see the difference between the admin and editor.

October 30, 2019 at 11:01 pm #4859699

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

Please check again and let me know your results.

When I sent the translation BI Specialist for the translation I was able to take it with my editor account and access it as expected.

October 31, 2019 at 7:05 am #4860663

marijnS-2

I'm sorry Bobby, but it isn't working at my side at all...

I am still getting the translation of the single page template, like shown in my previous message.

I made a clean new user with an editor role. (Please let me know how to send it.) Added it as translator and tried again, but it directs you directly to an empty translation que. See screenshot.

It only work like it should with my admin account

October 31, 2019 at 7:46 pm #4867425

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I have enabled the private field reply so you can share the details of the editor account with me.

NOTE: Also please verify that the administrator account under WPML is still active as I cannot access it at the moment

Additionally please go back to your Avanti services dashboard and contact them as they should be able to mark the translations as complete from their side. The translations still show as "needs update", which should be able to be fixed from their side.

Let me know their feedback, please.

November 1, 2019 at 9:33 pm #4873085

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi Martijn,

I am able to confirm that this is working as expected within your staging environment.

1. With an admin account go to WPML->Translation Management->Pick a page/post/etc and sent it for translation(in the basket send it to "First Available")
2. Login now with the translator account and go to the "Translations" dashboard, and you will be able to take the page and translate it as expected.

---------

If with the translator account you instead go to Pages-> and click to Edit a translation or add a translation that has not been assigned to you as the translator you will not be able to access it and instead taken to the Translation Dashboard.

As long the WPML Classic Translation Editor is activated for the content or a specific page or post the Editor will need to create and assign a new job for translating the content on Translation Management. This is default behavior do to capabilities when using WPML.

Here is a workaround to this that the Editor can do:

The Editor is able to edit posts and pages that been created and translated by an admin and not assigned to them, by changing the switcher for the WPML Translation Editor inside the language options of each post type (see screenshot). Disable the Translation editor for single posts or pages and you will be able to edit manually on the WordPress Editor.

1. As an editor go to Pages
2. Edit default language of the page
3. Click on the switch to " Use the WPML translation editor" and turn it off.
4. Now the editor can directly access the translation if it's not assigned to them.

IF instead you want the editor to access the translations using the Classic WPML Translation Editor then you will need as an admin to assign these pages/posts/etc as jobs to them.

November 4, 2019 at 8:55 am #4878751

marijnS-2

Hi Bobby,

I have contacted Avanti about the request to change the status of their translations. They say: "We cannot change the status of uploaded files, this happens automatically. To be sure, I checked on the hub and all files have the status "delivered". See screen shot.

I hope we can make some progress as my client wants to get access and start adding translations. I don't prefer to give them full admin access.

Thanks,

Marijn

The topic ‘[Closed] Editor can't translate’ is closed to new replies.