This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Andreas W. 5 months, 4 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 16, 2019 at 7:10 pm #3625009

Pim Stigter

Tell us what you are trying to do?
Hi, i've created an editor role and it cant seem to edit translations (of any post type) that have been created by others. It can access the original language posts.

Is there any documentation that you are following?
I've tried a few topics on the forum. I added the editor as a translator and gave it all the languages. I also tried toolset Access plugin and followed this guide, but nothing changed. https://wpml.org/documentation/translating-your-contents/how-to-use-access-plugin-to-create-editors-for-specific-language/

Is there a similar example that we can see?
??

What is the link to your site?
hidden link

The site is a copy of the live site, so it can be messed with.
I would like to provide login information, but not sure this is public or private.

April 16, 2019 at 9:22 pm #3625703

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Does the new Editor have permission to use the Advanced Translation Editor?

Please go to WPML -> Settings -> How to translate posts and pages and click the option "Advanced Translation Editor settings". Here you are able to see the current permissions.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

April 16, 2019 at 9:34 pm #3625737

Pim Stigter

Hi Andreas,

The advanced translation editor is currently not turned on. I tried turning it on earlier, but i got an error when 'synchonizing translators and translation managers'. "Advanced Translation Editor settings" also doesnt work.

And I don't see any box to leave my credentials ??

greetings

April 16, 2019 at 10:20 pm #3625821

Pim Stigter

Please turn on the private box.

April 16, 2019 at 10:45 pm #3625903

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please provide your reply in the next message, which is set to private by default.

Kind regards,
Andreas

April 17, 2019 at 3:00 pm #3632175

Pim Stigter

Any progress? Did you copy the site yet? I would like to revert to a backup if possible to test other stuff.

April 17, 2019 at 3:18 pm #3632275

Pim Stigter

I'm reverting to a backup (it doesnt have the editor user yet).

April 18, 2019 at 12:27 am #3635215

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I took a copy of your website an run it local.

I deleted WPML and its add-ons in order to replace them with the latest versions.

When trying to install a plugin I received the following error:

Deprecated: Function create_function() is deprecated in C:\wamp64\www\taotest\wp-content\plugins\simple-tags\simple-tags.php on line 80

I deactivated the Simple Tags plugin and tried to install the latest version of WPML and its add-ons when I received another error:

PHP 1. {main}() C:\wamp64\www\taotest\wp-admin\update.php:0
PHP 2. require_once() C:\wamp64\www\taotest\wp-admin\update.php:14
PHP 3. require_once() C:\wamp64\www\taotest\wp-admin\admin.php:34
PHP 4. require_once() C:\wamp64\www\taotest\wp-load.php:37
PHP 5. require_once() C:\wamp64\www\taotest\wp-config.php:168
PHP 6. do_action() C:\wamp64\www\taotest\wp-settings.php:374
PHP 7. WP_Hook->do_action() C:\wamp64\www\taotest\wp-includes\plugin.php:465
PHP 8. WP_Hook->apply_filters() C:\wamp64\www\taotest\wp-includes\class-wp-hook.php:310

I then copied the plugins into the wp-content/plugins folder and activated them.

Next, I opened some new translation jobs on Translation Management and then logged in as Editor (Redacteur). I was able to take and translate the translation jobs from Translation Management and I also had access to other post types.

Please take note that on your site the posty type "Posts" is currently set to "not translate" in the global settings at WPML -> Settings -> Post type translation.

Possibly, the issue was caused due to the Simple Tags Plugin which I mentioned earlier on this message.
Could you please disable the plugin on yours site to see if this solves the issue?

Further, if so, please recreate the issue on the following test site in order to escalate it to our compatibility team, who will reach out to the plugin authors in order to solve the problem.

One Click Login: hidden link

I will be out of office until Monday and I beg you for some patience until I will be able to take care about your request again. I wish you a nice weekend.

Kind regards
Andreas

April 18, 2019 at 10:26 am #3638263

Pim Stigter

Hi, thank you for looking at the problem.

I noticed you make a job for the editor for the editor to be able to translate. But an admin doesnt have to make this job to be able to edit a translation. We would like an Editor to be able to instantly edit a translation, not by making a job first, is this possible?

April 22, 2019 at 5:13 pm #3657359

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message and my apologies for the delay on my answer.

The User with the role Editor will be able to assign translation jobs himself only if a Admin adds him as Translation Manager in Translation Management. Also make sure to assign the Editor as Translator for any respective language pair.

You can see an example on the following sandbox site:

One Click Login: hidden link

Check the translator roles. Then log-off and sign in as Editor.

WPML Editor - Password: 7P7f5NFVx1OOuAS^gaAjpyIH

Let me know fi you do have any further question.

Kind regards
Andreas

April 22, 2019 at 5:42 pm #3657549

Pim Stigter

Hi Andreas,

Thank you for replying. I am not sure if you fully read my last question. I know how to have the Editor role make jobs for himself. But an admin role doesnt need to make this Job at all to be able to edit a translation. Is there a way to give the Editor role this power?

greetings, Rudolf

April 22, 2019 at 9:49 pm #3658443

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

The Editor will be able to edit any post, page or other content instantly without creating a translation job. In order to be able to translate he will need to assign himself the role as translator or be assigned as translator by an admin who is translation manager.

If you log into the test site of my last message you will be able to see that the Editor can edit content or translate it directly on the WordPress Editor and he will further be able to assign translation jobs for others or himself.

You will need to assign the Editor of your site as translation manager and then assign him as translator for all available language pairs in order to give him the above described capabilities.

In case this will not have the expected effect on your live site please provide me access to an editor account.

You next reply is set to private by default.

Kind regards
Andreas

April 23, 2019 at 9:56 am #3661579

Pim Stigter

Hi,

I logged in to your sandbox and created a new page (test 1 EN). Then i went to dashboard > page and clicked on the + for this page to create the german version.

Then I logged in with the Editor and went to dashboard > pages and clicked on the pencil for that page. I end up in the screenshot and not on a page that translates the post.

April 23, 2019 at 2:53 pm #3665075

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

As long the WPML Translation Editor is active you will always be forwarded to the section in the dashboard that is shown on your screenshot. If you go to the page editor and change the language option setting for translating without WPML Translation Editor you will be able to translate manually.

See screenshots attached.

Kind regards
Andreas

April 24, 2019 at 11:16 am #3672001

Pim Stigter

The Editor password on your sandbox wasnt working so i changed it back.