Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 17 replies, has 3 voices.

Last updated by nicolaD-10 10 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
March 4, 2019 at 4:14 pm #3269804

carlaM

I am trying to: translate as Editor Role

Link to a page where the issue can be seen: (internal)

I expected to see a post translate (pencils icon)

Instead, I got: pencils in gray

Every user has permission to translate at Translation Management.

March 5, 2019 at 8:42 pm #3276025

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Please go to WPML->Translation Management-> Translation Roles-> Please verify that you have added this editor as a translator and that they also have the ability to translate in the specific language pairs

let me know your results please

March 6, 2019 at 9:54 am #3277915

carlaM

Hello Boby, Every user can translate and always have been able to translate content.
I'm sending you a screen. Please, let me know i f you need access so we can solved this issue as soon as possible.

Thanks, best regards
c

March 6, 2019 at 10:05 am #3278094

carlaM

One more thing to help understand the problem. The Editor can see the boxes to duplicate a post. But when an Editor click/check a box to "duplicate" a post it doesn't work.
Thanks.

March 6, 2019 at 6:13 pm #3280902

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

There might be an index missing from the database , i would like to take a closer look if possible

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

March 7, 2019 at 3:20 am #3282161

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

i created an editor and I sent the following for translation hybrid and equipament

Once i logged in with the editor role i was able to edit the 2 pages.

additionally i was able to access and edit any other post available

March 7, 2019 at 10:39 am #3283591

carlaM

Hello Bobby, we don't use this translation management editor.
The client use the classic one.
Please advice.
Thanks
c

March 7, 2019 at 5:55 pm #3286222

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

This was the automatically assigned one for me to switch it , you can go to
WPML->Settings->Translate Manually

Note: for visitor01 its set to use the Translation Editor.

i used my new editor role and went back to one of the posts , to edit using the classic translation editor i just went to posts->edit default language post and used the language switcher on top of the page to switch to secondary language

are you still experiencing issues with the other editor account ? if yes i would need access to their editor account as i am not able to replicate the issue with the new editor account.

March 8, 2019 at 11:11 am #3291556

carlaM

How can i send you a private message with both Editor access data?
thanks
c

March 8, 2019 at 7:03 pm #3295052

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

next reply will be private , thank you !

March 11, 2019 at 1:46 pm #3313213

carlaM

Hello Bobby, client is, since Friday, working with the user visitor01 that you used until they users work fine.

I don't know why but cliente has create a new post with user Visitor01 - and the picture inside the post does not open as usual when public. I mean, usually you click on the picture and it opens to a bigger version. Could you helpe us with this please?
hidden link

Thanks,
best regards
c

March 11, 2019 at 8:19 pm #3316537

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

The issue with the media is because you need to edit the media within the post and then select "link to a URL " and assign the media url to it. (screenshot)

Regarding the default issue here ,i have test both Editor accounts and i was able to access the translations and edit them, etc.

the only thing i was not able to do was "duplicate".

This is a known issue that our developers are currently working on resolving , i will be escalating this ticket , and once we have news i will be updating you here.

at the meantime your editors can do the following as a workaround if they need to duplicate.

1. Access the translation and use "copy from "default language" " or "overwrite content with..." these two buttons do the same action as duplicating but they are just access through the translation page.

March 12, 2019 at 12:57 pm #3322263

carlaM

Hello Bobby,
OK. we'll be waiting for a solution for the Editor users.
thanks
c

March 29, 2019 at 12:11 pm #3491143

carlaM

Hello I have the same issued with other website. This time with Bridge theme
Please help.

March 29, 2019 at 8:46 pm #3494871

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

The issue has been escalated to our developers team , i have also provided a workaround for the meantime in my previous thread

once i have news i will update you here