This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Jamal 8 months, 3 weeks ago.

Assigned support staff: Jamal.

Author Posts
January 21, 2019 at 8:10 am

yoon-perngK

I've two WordPress users, one Administrator and one Editor

1) wpmladmin (Administrator)
2) ray7117 (Editor)

The "Additional Capabilities" for both users are the same :
1) manage_translations
2) translate

* By the way, not sure how the "Additional Capabilities" was set up, I didn't do anything explicitly

1) If I logon as wpmladmin (Administrator) and click on the "pencil" icon of a post previously translated, I'm sent to the "classic translation editor" page, which is correct.

1) If I logon as ray7117 (Editor) and click on the "pencil" icon of a post previously translated, I'm sent to the "Translations queue" page, which is NOT what I want, I want it to open the "classic translation editor" page instead.

How do I make user with "Editor" role behave the same as Admin user for WPML during translation

This is the screencast of my problem--> hidden link

* Copy the link above to a new tab if not able to view

I'll send you the site info for you to login to test. The site is actually a Cloudways site your collegaue help me to set up for another ticket here--> https://wpml.org/forums/topic/category-problem-for-translated-page/

Both these users has the same password.

1) wpmladmin (Administrator)
2) ray7117 (Editor)

January 21, 2019 at 11:46 am #3112117

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I can confirm that the credentials work.

Can you also please provide the login information for the second account you are talking about above (not the main admin account, but the "Editor" one) ?

Also, can you please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

Thank you!

I will be waiting for your response.

Kind regards,
Mihai Apetrei

January 21, 2019 at 1:16 pm #3112572

yoon-perngK

Hi Mihai

Thanks for the reply.

In my original post, I 've already stated "Both these users has the same password."

Also, I've pasted the debug information.

Thanks.

YP

January 21, 2019 at 5:45 pm #3113531

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Ok, that's amazing.

I might have missed that, sorry.

I will need to spend some time debugging this and I will get back to you as soon as I have more info.

Just wanted to keep you updated.

Kind regards,
Mihai

January 23, 2019 at 1:55 pm #3120874

yoon-perngK

Hi Mihai

Any update on this?

Thanks

YP

January 23, 2019 at 3:38 pm #3121303

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

After some debugging and multiple tests, it seems that whenever I disable the WPBakery plugin, "Edit" works from the other user, too.

Also, it seems that whenever WPBakery was enabled, there was no way for me to switch to the Gutenberg editor - there was a button in the normal WordPress Edit page to switch to that but it was greyed out and even if I clicked it, the page was automatically refreshing and then nothing happened, the editor would remain WPBakery.

This looks like it might be a compatibility issue and in order to be able to send this further to the compatibility team, I will need you to do a couple of things first.

I created this sandbox environment here for you:
hidden link (one-click automatic login)

I would need you to just upload the WPBakery plugin there, create an extra user that is on WordPress "Editor" level, create a new post in multiple languages and then reproduce the issue.

After that, please let me know and I will check it. If things happen on our staging server, too, I will escalate this to our compatibility team.

I will be waiting for your response.

Kind regards,
Mihai

January 24, 2019 at 5:28 am #3123438

yoon-perngK

Hi Mihai

You didn't solve the problem by disabling WPBakery, an editor is able to translate posts created by the same "editor".

I've done this:
1) Created another "Editor" - testeditor1, same password as the rest.
2) Added "testeditor1" as translator
3) Login as testeditor1
4) Try to transalet a post created by another editor: ray7117, it went to the "Translations queue" page. So problem is not solved by disabling WPBakery editor.

By the way, I DO NOT want Gutenberg editor to be enable.

1) Also, I've uploaded the plugin WPBakery onto the sandbox site
2) Created two "editor" users and tested, same problem, the "editor" can only translate a post created by itself, not posts created by other "editors"

You can create some new "editors" for testing on the sandbox site.

Thanks.

YP

January 24, 2019 at 5:50 am #3123474

yoon-perngK

Hi Mihai

Just to be very clear. I need:

1) ALL editors to be able to translate ALL posts and ALL pages, no matter who created the pages/posts.

Thank you.

YP

January 24, 2019 at 8:14 am #3123885

yoon-perngK

Hi Mihai

Update my previous post.

1) ALL editors to be able to translate ALL untranslated posts and ALL untranslated pages, no matter who created the pages/posts.
2) ALL editors to be able to RE-TRANSLATE ALL translated posts and ALL translated pages, no matter who created the pages/posts.

Thank you.

YP

January 24, 2019 at 12:25 pm #3124971

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello YP,

Mihai is not working today, so i will try to answer you.

I have seen your screencast, and regarding the example in the video. Ray7117 was not able to edit the translation because the job responsible for it was already assigned to you.

When working with Translation management the editor role is a must to have. But Translation Management can check jobs and allow/deny updating a translation.
If you want the translation job to reappear for the user Ray7117 you will need to "Resign" button in the bottom left of the classic translation editor. See attached image.
I resigned "WPML test without content builder" using wpmladmin user. Then it showed up on Ray7117's translation queue.

So when using Translation Management for translation, the Editor user will not be able to edit translations that are part of an assigned translation job.

I hope this answers your question. Let me know if it does not.

Best regards,
Jamal
WPML Support

January 24, 2019 at 4:08 pm #3126026

yoon-perngK

Hi Jamal

Thanks for the reply.

Is it possible to allow the followings:

1) ALL editors to be able to translate ALL untranslated posts/pages, no matter who created the pages/posts.
2) ALL editors to be able to RE-TRANSLATE ALL translated posts/pages, no matter who created the pages/posts.

Is very troublesome to have to re-assign every time we need someone else other than the author to translate the page.

Thanks

Regards
Khong

January 25, 2019 at 9:38 am #3128318

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

What you are asking is the default way of WordPress besides WPML, Editors can edit and publish any content even if created by other users.

You can have this without using Translation Management. But actually deactivating Translation Management can have side effects, especially when using a page builder like WPBakery Page Builder.

I suggest that you you keep the current content translations within Translation Management, and adapt with this restriction, first translator must resign an assigned job. And translate the future content the old way, without sending translations jobs.

If you want to deactivate completely Translation Management, Please make a backup, to revert back if any issues happen.
Go to WPML->Translation Management->Translation Jobs, and cancel all jobs.
You will need to switch to manual translation in WPML->Settings.
Then remove all translations that have been created with Translation Management. For pages in Pages->All pages, for posts in Posts->All posts. For all secondary languages.
You will also need to remove these pages/posts completely from the trash.
Then deactivate Translation Management.

At this state, WPML will suggest to use Translation Editor when it detects WPBakery.
And you will be able to work the WordPress way, all editors will be able to edit and publish all translations.

I hope this answers your question. Let me know if you have any doubts.

Best regards,
Jamal
WPML Support

January 25, 2019 at 2:59 pm #3129489

yoon-perngK

Hi Jamal

I've found many people asking the same questions as me and the support team recommend using the "Access" plugin. How do I download the Access plugin?

https://wpml.org/documentation/translating-your-contents/how-to-use-access-plugin-to-create-editors-for-specific-language/

This link https://wpml.org/plugin/access/ brings me to https://toolset.com/home/types-access/.

I believe this is free for WPML user, how do I download?

Thanks

January 25, 2019 at 3:17 pm #3129571

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I did not suggest using Access as the promotional download we were offering has ended.
Now it requires buying a Toolset license. We are giving a 30% discount to WPML clients.
https://wpml.org/account/offers/

Best regards,
Jamal
WPML Support