Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.99 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 years, 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 15, 2016 at 8:14 pm #1003789

gvidoD

Hi!

When i try to fill the set up steps for WPML plugin, i cannot click the next button, therefore i cannot complete the setup and use the plugin! I got stuck in 3rd step, where i need to set up language switcher

I checked the console and i see "An invalid form control with name='icl_lang_sel_footer_config[border]' is not focusable." from admin.php

I can provide access to the page if needed.

Thanks !

August 16, 2016 at 4:14 am #1004191

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

This error basically happens when a theme or an plugin use wpml-config.xml file and set the color property of some language switcher to transparent. To solve the issue, could you please go to your theme files and check wpml-config.xml file and search for the following code

<key name="border">transparent</key>

and replace it with

<key name="border">#cdcdcd</key>

Please let me know if this helps? If still the issue exists, please let me know.

Thanks

August 23, 2016 at 5:27 pm #1017634

gvidoD

Hi!

I edited the code in my main template folder. But it doesn't help . Do i need to do some theme reactivating or something for this to take the effect? i am also using childs team and this file was located in main theme folder.

August 24, 2016 at 2:34 am #1018126

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Please follow the below steps to fix the issue:
1) Install twenty-sixteen theme
2) Complete the WPML installation Process
3) Go to WPML->Languages->Language switcher options -> Footer language switcher style
4) Click the "Edit the footer language switcher colors" link
5) Go to border color and choose any color.
6) Activate the current theme with changed wpml-config.xml file.

Please let me know if this helps, I look forward to your reply.

Thanks

August 30, 2016 at 8:12 pm #1038349

gvidoD

Hi!

I activated twenty-sixteen theme, but cannot complete wpml setup. Same error appears. I also tried to deactivate and activate wpml plugins. I am willing to provide access details if needed .

Thanks you for help!

August 31, 2016 at 2:51 am #1038656

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

I look forward to your reply.

Thanks

September 1, 2016 at 3:10 am #1047936

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please check the issue once, I am fixed the issue. To fix the issue, please follow the below steps:
1) Go until step 3
2) On step 3 click the link "Edit the footer language switcher colors"
3) Once clicked go to "Border" and click select color and choose any color.
4) Press Next.

Please let me know if that helps.

Thanks