This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Itamar 9 months ago.

Assigned support staff: Itamar.

Author Posts
January 11, 2019 at 2:14 pm #3081072

saskiaR-2

Hi there!
We have a website with three languages. Everything is made with Elementor. The Elementar front-end toolbox has always the same language then the page we are editing. The Problem is, that we don't speak Italian. How do we can change this? It should be always english.
We already set de Admin language from the user to englisch. The WordPress Backend is always english, but the Elementar frontend toolbox not.

This is the same issue as in this topic: https://wpml.org/forums/topic/elementor-front-end-toolbox-does-not-use-my-admin-language/

But there is no final solution to this problem.
Thanks in advance for your help!

Best regards,
Manuel

January 13, 2019 at 9:35 pm #3085244

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Since Elementor editor is working on the front-end, it will always be in the same language as the language of the post that you are editing. It will be like this regardless the admin language that is set in the user's profile.

Nevertheless, here is a workaround that I've found that might enable to achieve what you need.
1. Go here hidden link and export the .mo file (it is the Canadian English translation for Elementor).
2. Connect to your site with FTP and go to this location /wp-content/languages/plugins/.
3. Remove the elementor-it_IT.mo file.
4. Change the name of the Canadian English file that you have exported to elementor-it_IT.mo
5. On your site's admin go to WPML -> Theme and plugins localization -> Localization options and set the option 'Don't use String Translation to translate themes and plugins' and save.
6. Through FTP upload the new elementor-it_IT.mo (with Canadian English content) file to /wp-content/languages/plugins/.
7. Again in WPML -> Theme and plugins localization -> Localization options set the option 'Translate themes and plugins using WPML's String Translation and always load .mo files as backup' and save.
8. Still on the same location now select the option 'Translate themes and plugins using WPML's String Translation only (don't load .mo files)' and save.
Now you should be able to see English for the language of the Elementor toolbox even if you edit an Italian post or page.

Please let me know if this information is helpful to you.

Regards,
Itamar.

January 13, 2019 at 9:37 pm #3085245

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi again.

Please take a backup of your site before trying the above suggestion.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

The topic ‘[Closed] Elementar toolbox different languages’ is closed to new replies.