Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 3 voices.

Last updated by Carlos Rojas 2 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 11, 2019 at 10:13 am #4552427

nicklasL

We have translated the content of a WooCommerce web shop from Swedish to english.
After activating Elementor, we get a Fatal Error each time we try to edit the description of a product (the upper editor content).

The fatal error we get is this:

---
Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Elementor_Register_Strings::register_strings_for_modules() must be of the type array, null given, called in /site/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/compatibility/class-wpml-page-builders-register-strings.php on line 57 and defined in /site/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-register-strings.php:12 Stack trace: #0 /site/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/compatibility/class-wpml-page-builders-register-strings.php(57): WPML_Elementor_Register_Strings->register_strings_for_modules(NULL, Array) #1 /site/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/class-page-builder-integration.php(61): WPML_Page_Builders_Register_Strings->register_strings in /site/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-register-strings.php on line 12
---

We are using the latest WPM plugin versions, upgraded today.
Also, we are using the latest versions of WordPress, Elementor and Elementor Pro.

The error occurs as soon as we press the publish button after editing the product.

It doesn´t help if I disable the advanced translation editor or not - the error occurs anyway.

September 11, 2019 at 11:12 am #4552883

nicklasL

This ticket was moved to Email support- how do I send the Duplicator package now?

September 11, 2019 at 7:17 pm #4556113

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

i have enabled the private field reply to share the duplicator

September 13, 2019 at 12:19 pm #4568531

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Nicklas,
My name is Carlos and I will be taking this ticket because our colleague Bobby is on vacations.

Thank you very much for sharing the copy of the site. I was able to reproduce the issue and after running several troubleshooting test I have escalated this ticket to our 2nd tier of support.

I will keep you updated about the evolution of this ticket.

Best regards,
Carlos

September 13, 2019 at 12:44 pm #4568685

nicklasL

Thanks Carlos, for helping us out with this important issue.
Looking forward to a report from the 2nd tier of your support.

Have a nice weekend!

Best regards,
Nicklas

September 13, 2019 at 1:05 pm #4568749

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Nicklas,

Thank you very much for your understanding.

Have a nice weekend you too!
Regards,
Carlos

September 16, 2019 at 9:49 am #4578273

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Nicklas,

A similar issue was reported already and it was solved by installing the Dev version of WPML plugins. Please install the Dev version of WPML and let me know if the issue was solved.

Regards,
Carlos

September 18, 2019 at 8:19 am #4593659

nicklasL

Hi Carlos,
Thanks for your reply - by the DEV version - do you mean the latest beta, Version 4.3.0-b.8 ?
If not, please supply a link to the version that you mean.

September 18, 2019 at 9:00 am #4593997

nicklasL

Carlos,
I found the way I could switch channel and install Beta or Development versions, through your documentation.

However - it only lets me switch to the Beta channel. The development channel is not available. How can I get access to it?
See attached image.

September 18, 2019 at 10:53 am #4595315

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Nicklas,

Please test with the beta version first and double check if the issue persists.

Regards,
Carlos

September 18, 2019 at 11:03 am #4595443

nicklasL

Hi Carlos,
I have already tested with the latest beta. The problem persist. So I guess I need to get hold of the development version.

September 18, 2019 at 11:35 am #4595855

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Nicklas,

In this case I will consult our specialists and I will get back to you as soon as I get an answer.

Regards,
Carlos

September 18, 2019 at 11:47 am #4596001

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Nicklas,

I consulted our specialists and this issue will be fixed in the next release of WPML plugin. So far the Dev version is still unstable and might contain bugs so should only be tested by our development team at this moment.

As a workaround our specialists recommended this steps:
- Delete the translation (from the trash as well), do a small modification on the page content (original language) then translate it again.

Could you tell me if the workaround solved the issue in one of the pages?

Regards,
Carlos

September 18, 2019 at 8:59 pm #4599899

nicklasL

Hi Carlos,
I will try that, but it is not a feasible option for us, as there av hundreds of products.
When will the next version be released? If you don´t have a date - can you tell me if it will be in a few weeks, or next year?

Thanks,
Nicklas

September 19, 2019 at 10:05 am #4603361

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Nicklas,

When exactly our developers will release a Update including the required Fix is not up-to us Supporters to determine. But they are already working on it.

Each issue reported in is taken seriously into consideration.

It is given a high or low priority based on a number of factors.
Factors which those with the overview of all things related are in the best position to determine.

Thank you very much for your understanding!
Regards,
Carlos