This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Rohan Sadanandan 2 months ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
August 19, 2019 at 9:50 am #4414969

edB-3

I am trying to: translate elementor buttons and SVG link URL's.

After translating the page I expected to see: The correct link URL's for Buttons and SVG widgets, for the translated page.

Instead, I got: URL's to the default language.

August 19, 2019 at 1:12 pm #4416287

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

Could you please try the solution given on top of this ticket:
https://wpml.org/forums/topic/svg-not-working-in-translation-using-elementor-plugin/

Also, please enable the Debug Information so that we can provide faster support.

Please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Thanks,
Rohan

August 19, 2019 at 1:21 pm #4416335

edB-3

Hey Rohan

Thank you for getting in touch. I've have come across the thread you provided already. I have not actually tried to implement the solution, but the last message on the thread was created over a year ago. Surely WPML have come up with a feasible fix since then, rather than hacking it?

Thanks

August 19, 2019 at 3:06 pm #4417041

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for sharing the debug information.

Are you creating a duplicate of the page?
Have you updated the URL's for buttons & SVG widgets in the translated page?

Please share the URL of the page having the issue.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Also, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

Thanks,
Rohan

August 20, 2019 at 8:08 am #4421435

edB-3

I am able to change the URL's in the translated page. But every time i update the master page and re-sync the translated page (to pick up on other changes), the URL's are overwritten with what is in master.

I don't think access to the site will help to be honest. According to this thread a fix for the buttons was released, but is not working. https://wpml.org/forums/topic/elementor-slides-button-link-not-translatable-nor-redirecting-ot-translated-we/

Thanks

August 20, 2019 at 12:19 pm #4423479

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

The page content is synced only if the page is duplicated.
If that is the case, then all the contents you have made will be copied to the translated page when a change is made in the master page.

If you want to change this, you can click on "Translate Independently" on the translated page.
You can read more about this here: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

If you have any doubts, please let me know.

Thanks,
Rohan

August 20, 2019 at 12:56 pm #4423803

edB-3

Hey

Some elementor widgets automatically translate the links, even if they page is duplicated. Why are SVG and especially Buttons not translatable?

Thanks

The topic ‘[Closed] Elementor Button and SVG widget links are not translatable’ is closed to new replies.