This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Bigul 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 29, 2018 at 12:43 pm #2775613

Eva

I am trying to: My site's main language is Hungarian, but I ALWAYS use English as admin language. It is set to English, and despite this, when I write a post in Hungarian, the Elementor Pro toolbox (elements) on the front-end editor switches languages.
This is confusing, the translation of the elements to Hungarian is bad, and I don't want to switch languages when using any plugin. It was ok before, Elementor Pro admin used the language that is my admin language on the site.
Please fix this, as it's really irritating. I tried to to switch admin languages, then switch it back to Engish, but still doesn't work. So what I would like, is regardless of what language I use for a post, I want to see Elementor Pro elements in the same language as my WordPress admin, which is English.
Thank you.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

October 1, 2018 at 6:10 pm #2779131

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit Users>>Your Profile and make sure you have selected *English* as the Profile Language. Check the attached images for more details.

Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the other plugins that are not related to WPML and Elementor
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

October 2, 2018 at 12:56 pm #2781462

Eva

Hi Bigul,

Thanks for your reply.
As I said, my language is set to English, that has not changed. If I change the theme, I'm afraid it will mess up my whole page and I don't want to do that. Any better idea for fixing this problem? Or are you sure it will not mess up the forms I created?

Thank you
Eva

October 3, 2018 at 9:16 am #2784004

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Eva,

Thank you for the updates. I have a requested it to track the issue. Because maybe it will be happening because of the compatibility issues. It will be okay and I will check it further.

So please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

October 3, 2018 at 5:38 pm #2785406

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Eva,

Thank you for the login information. It may be happening because of the compatibility issues(Elementor not loading for English pages). Have you switch the default language of the site(in WPML>>Languages>>Site Languages) to *Hungarian* from *English* in the past?

Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

October 3, 2018 at 7:15 pm #2785498

Eva

Hi Bigul,
I'm so grateful that you are trying to help, as I'm really frustrated when things that I don't understand, happen.
Yes, I changed the main language a few days ago, because I read on a forum, that that might solve this admin language issue.
What happened now, and I'm again not sure why (maybe cause I disabled all the plugins and then reactivated them) that parts of my opt-in boxes disappeared.
I am able to access the Elementor Pro editors on these pages, but still not able to access on the English main page - hidden link, where the sign-up form is still visible.
So please yes, make a duplicate and I hope you can help with the problem.
These pages seem to be fine now - hidden link
The sign up box there now is saved among my templates.
Yesterday I saved some of these sign-up boxes among global widgets. Could that be a problem? I deleted those now, but I still cannot access the English main page.
THank you for your support.
Eva

October 3, 2018 at 7:17 pm #2785499
Eva

Ps: there was another bug I noticed in the past weeks - that despite the language of the page I'm editing, the templates I created come up from the language of the other page. That seems to be mixed up too. This is also something that did not happen earlier.

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-elementor-front-end-toolbox-does-not-use-my-admin-language/

October 4, 2018 at 12:58 pm #2787555

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Eva,

Thank you for the permission and updates. I made a Duplicator copy of your site now. Will debug it further and get back to you as soon as possible. Please wait.

Please note, I have opened a new ticket for the Language mixup in Edit page issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

--
Thanks!

Bigul

October 4, 2018 at 2:42 pm #2787856

Eva

Hello Bigul,
Thank you for your continued support!

Ok, so this topic is the admin language on front-end editor of Elementor.

It seems logical, that if the page I'm editing is in Hungarian, then the front end editor is also Hungarian. But I don't like it. 🙂
This has changed just some weeks ago, as it wasn't like this earlier. Both front-end languages were the same, and it was easier to edit that way.
Would there be a way around it? Perhaps some other people find it difficult too, to get used to the translated names of the elements.
Also, there is a mix up here with the element translations too. I'm attaching a picture of an English page I'm editing - as you can see, most of the element names are in English, as they should be, however, on the top, instead of ELEMENTS and GLOBAL, it brings up the Hungarian translation - ELEMEK and GLOBÁLIS. This is not good.:(

There is something funny though that I just noticed - The elements' language is changed only for Elementor widgets, not for Elementor Pro. The next picture is of a Hungarian page showing that Basic elements are in Hungarian, but pro elements are in English. If those can stay in English, then please let the Basic Elementor elements also be in Admin language.

Thank you so much
Eva

October 5, 2018 at 12:55 pm #2790739

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Eva,

Thank you for the details. I am not able to reproduce the issue exactly on my local server copy. The Elementor menu is showing for me in English while editing an English page using Elementor. When editing a Hungarian page using Elementor, most of the Elementor menus are showing in Hungarian. I have a request, please share me the URL of the English pages you have issues while editing with Elementor. I am enabling the private option for the next reply.

Have you completed the Translation of English homepage before having the issues? Or have you updated the Hungarian Homepage recently? It looks like the homepage translation is not completed yet - hidden link

Because on my local copy, the English homepage is loading in Elementor after the following steps. Please try it after a site backup and let me know your feedback. But some translations are missing in the English homepage after this step.

1) Open the Hungarian Homepage for edit
2) Click on *Pencil* icon(English Translation) of the Language widget(on the right side)
3) Complete the Translation or mark all the checkboxes as translated from WPML Translation Editor
4) Save the translation
5) Then check Elementor is loading for the English Homepage or not

Please check the attached images for more details.

--
Thanks!

Bigul

The topic ‘[Closed] Elementor front-end toolbox does not use my admin language’ is closed to new replies.