This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 22 replies, has 2 voices.

Last updated by anthonyG-18 11 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
September 21, 2018 at 2:23 pm

anthonyG-18

I am trying to: use translated global widgets

Link to a page where the issue can be seen: hidden link

I expected to see: all the translated global widgets available

Instead, I got: a few of them only

September 24, 2018 at 4:51 pm #2761385

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I notice that when I view your Global Widgets in French, the list displays 14 widgets. But the count shows 45, so something seems off. Please be sure to make a full backup of your site and database. Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

After this, do all of the global widgets appear?

September 25, 2018 at 8:13 am #2762921

anthonyG-18

Hello Lauren,

I've followed the steps, but it hasn't changed.

However, in the meantime, I have created a new global widget (Header - Chevron), and this one appears (screenshot attached).

Regarding the total count you were talking about, I think it refers to the total number of items whatever the type (global widgets, sections, etc), because when i am on the "All" tab, this is the exact number of templates.

September 25, 2018 at 9:44 am #2763253

anthonyG-18

A quick update : I have translated a page from default language to English using the ATE, and I can't edit this page with Elementor anymore (blank screen) : hidden link

It contains some translated global widgets, if that may help you identify the issue.

September 25, 2018 at 3:57 pm #2764642

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the updated information. If you temporarily disable WPML, do you see the correct amount of Global Widgets in the Elementor editor in your default language?

If so, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except Elementor Pro and WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, do all of the global widgets display?

September 26, 2018 at 10:53 am #2766889

anthonyG-18

Hello Lauren,

I've tried this but it doesn't change anything.

September 27, 2018 at 2:06 pm #2770794

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was also able to create a new global widget and get it to appear. Please try editing and updating the original global widget (I think you open the page where the widget was created and make some change, and save the changes). Then, update the translated global widget as well. Does it now show up in Elementor?

As for translating pages with Global Widgets in Elementor, this is a known issue that our developers are currently working to resolve.

September 28, 2018 at 11:53 am #2773638

anthonyG-18

I've tried that. It doesn't resolve the issue.

September 28, 2018 at 2:25 pm #2774216

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If you re-create one of the global widgets from scratch, and then translate it, does it then appear?

September 28, 2018 at 3:38 pm #2774330

anthonyG-18

Yes, it woks indeed. So this means I need to recreate all the default languages and then retranslate them ... no other solution possible ?

September 28, 2018 at 4:23 pm #2774412

anthonyG-18

Edit : I have tried to delete a global widget and recreate it in order to translate it, but this time it didn't work...

September 28, 2018 at 4:23 pm #2774413

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It seems so. I'm not sure what happened to the existing ones, perhaps there was some glitch in the database? But since I can't recreate the issue when creating a template, it's hard to troubleshoot why the others are not showing up. I wish I had a better solution for you.

September 28, 2018 at 4:43 pm #2774441

anthonyG-18

Yes, I confirm, it doesn't work anymore. I've tried with a new global widget and it doesn't show up in the Elementor editor. It seems so sporadic.

September 28, 2018 at 6:07 pm #2774592

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

One last question before I escalate. After you deleted the global widget, did you delete it permanently from the trash before trying to recreate it?

September 28, 2018 at 6:38 pm #2774653

anthonyG-18

Yes, I've deleted it permanently and purged everything after that.