This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: L'utilisateur rencontrait un problème avec le header Elementor sur la langue secondaire Solution: Le client a corrigé l'erreur en créant un nouveau Header Elementor.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by julienE-2 1 month, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
September 2, 2019 at 3:06 pm #4498067

julienE-2

I am trying to:Have elementor header template appear in translated pages

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
The header

Instead, I got:
Nothing

- The Header template is translated (either way as I understand it it should appear in original language even if I dont translate it)

- The footer, oddly enough, has the exact same settings, and appears fine.

- the strings are fully translated for 2 of my languages

- I did try with the code provided by support:
//Elementor fix to have global templates appear in translations
add_filter( 'elementor/theme/get_location_templates/template_id', 'templated_id' );
function templated_id($theme_template_id){
if (!is_admin()) {
$theme_template_id = apply_filters( 'wpml_object_id', $theme_template_id, 'elementor_library', true );
}
return $theme_template_id;
}

Please advise,

Julien

September 2, 2019 at 5:23 pm #4499395

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Julien,

Thank you for contacting WPML Support. I will be glad to help with this.

For the primary language, I suspect that the template does not have language information attached. Please go to WPML->Support->Troubleshooting and run the action to "Set language information". Please don't ignore the database backup notice.

For the secondary language, If the issue persists, I would say that the option to use the footer should be translated as an option following this document https://wpml.org/fr/documentation-6/guide-de-demarrage-rapide/traduire-les-options-de-theme-et-de-customizer/

It's probably similar to this ticket which is related to the footer template!
https://wpml.org/forums/topic/select-translated-elementor-templates-in-theme-options/

Let me know if this helps! Otherwise, please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Jamal

September 3, 2019 at 11:49 am #4504043

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I understood that the issue is about the header, and wanted to provide a "similar" case which is actually about a footer. My apologies, I also talked about the footer when I should have said header. It is similar as they both may be related to theme options(header, footer, layout, etc.)

But, this is probably related to Elementor Pro. A bug that was introduced in the recent releases(10 releases in 2 months).

Right now, the homepage has a different template than "Elementor canvas". Unfortunately, the translated(French) header is actually not assigned to any page, see attached image(translated-header-instance.png).
Je suggère d'ouvir le header traduit(Entete 3) avec Elementor et de mentionner une condition d'affichage sur le site en entier(elementor-conditions-affichage.png).

Let me know how it goes.

September 3, 2019 at 1:37 pm #4504837

julienE-2

Hi and thanks for your followup.

I dont understand how that would be best practice. The English version is set to appear on the whole site, and one would expect the French version to be shown on the French pages without having to manually set that.

The footer, in fact, does exactly that. (this is where my mention of the footer becomes relevant).

Please advise.

September 3, 2019 at 4:45 pm #4506399

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I can agree with you, how that could be a best practice. We suspect that this bug(translated header losing display conditions) was introduced in the last Elementor Pro update(2.6.5 - 2019-08-26). It appeared in many clients sites, but we did not find yet a step-by-step way to reproduce this bug.

I only guessed that settings the display conditions on the translated Header manually can be a good workaround for now. Would you please test if it will work?

Best regards,
Jamal

September 3, 2019 at 6:16 pm #4506897

julienE-2

My issue is resolved now. Thank you! All I needed to do was recreate a new header. Maybe the old one had some funky data attached.

How I resolved.
- Created a new header and copy pasted the template from previous header.
- Removed site wide conditions to old header and added it to new header

It all seems to work.

Something quite notable: I only have an English version of this header and it appears fine everywhere, with correct menus and language switcher etc.

Jamal, thanks very much for your diligence. I had misunderstood at first that it was a workaround that you were suggesting. I didnt get to testing it as my problem was resolved before.

Thanks