This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.92 hours from now. Thank you for your understanding.

This topic contains 4 replies, has 2 voices.

Last updated by christopheG-9 3 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
June 17, 2019 at 2:53 pm #4036353

christopheG-9

I am trying to: Translate an Elementor heading that links to a page.

From a blank page, i create a heading in English that links to an English page. Following the recommended procedure, i duplicate the page into Spanish and then edit the translation.

Problem: the translated Spanish header sends to the English page, and the URL is nowhere to be found in String Translation

June 17, 2019 at 3:01 pm #4036423

christopheG-9

When i replicate this but use 'text' instead of 'header' in Elementor, the link is translated with no issues.

June 17, 2019 at 11:51 pm #4038983

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Can you please, provide me with the details on how to replicate the issue in your website? It will help me to understand what's wrong and this way to provide you with a detailed solution. Also, I would need to take a detailed look in your WordPress Dashboard, for that, please consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

June 18, 2019 at 6:33 pm #4045907

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case, I recommend you to try the following:

1 - In your WordPress Dashboard > WPML > Settings > Translate Link Targets click the 'scan now and adjust links' button. Wait for the whole process and test your translated spanish page again.

If the above doesn't help, then I recommend you to manually edit your spanish page using the Elementor page builder and adjust the link field to target your translated content.

Please, let me know if it helps, have a nice day.

July 8, 2019 at 2:58 pm #4163749

christopheG-9

This is unresolved i regret.

I re-saved the page, re-saved the translation and ran 'scan now and adjust links' on the 85000 links, did that twice, unfortunately the Spanish title still sends to the English page, whereas the hyperlink in the paragraph functions correctly.

Am i the only person having trouble with Titles in Elementor?