This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Thomas 1 month ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 5, 2019 at 3:12 pm #4520395

Thomas

HI WPML Team,

I am trying to: Translate the Elemenor widget "Image Box".

It is only possible to translate the Image Box description field with WPML translation manager. The field for URL is missing.

Thank you :).

September 5, 2019 at 6:04 pm #4521353

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 6, 2019 at 8:17 pm #4527283

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a detailed look in your WordPress Dashboard and noticed the issue, some themes and plugins provides custom Elementor modules that couldn't be ready for WPML and here it might be the cause of your issue. We can still try to let WPML scan all the links and adjust it to target the translated content automatically with these steps:

1 - In your WordPress Dashboard > WPML > Settings > Translate link targets click the button to scan and traslate your posts content links.

If it doesn't work, then we would need to confirm the compatibility issue in order to find a solution for that, for now the workaround for it should be editing those links manually using Elementor on the translated page.

Please, let me know the results, have a nice day.

September 9, 2019 at 9:55 am #4535723

Thomas

Hello,
I clicked the btton. Waited for half an hour to scan 21902 strings. And the result was that 0 links were changed :-/.

September 10, 2019 at 1:03 am #4540681

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case a compatibility issue should be the cause of your issue here, as said before, some themes provides custom Elementor modules not WPML ready, in order to confirm it, please, follow the instructions below:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

September 10, 2019 at 8:39 am #4543189

Thomas

https://wpml.org/de/2019/09/wpml-4-2-8-launched-through-staged-rollout/

WPML Core 4.2.8
Added the ability to translate the Image Box link in Elementor.

I installed the new version but the fields still not show up. What should I do to display them?

September 10, 2019 at 4:33 pm #4547327

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. As said before, your website is using custom Elementor modules, the WPML support added for image box is related to the default Elementor image box module. I've just tested it in the provided sandbox environment (hidden link) and the url fields appear properly for translation when a default Elemenot image box is used in the page content, as you can see in the 'Elementor #16' page.

For test purposes, you can recreate a page using your custom Elementor modules provided by the plugin of your WordPress installation called 'Elementor Addons von Netzlicht'. It will confirm the compatibility issue I am talking about. Thank you for your collaboration and patience, have a nice day.

September 10, 2019 at 5:11 pm #4547639

Thomas

Hello Marcos,

thank you for trying to help me. I really appreciate it.

I deactivated the plugin you mentioned. Only Elementor and Elementor Pro is active. I updated the staging environment to the latest versions (WPML, Elementor etc.)

On my staging environment I use the STANDARD image boxes:
hidden link

but the url fields are not showing up in translation mode:
hidden link

Is it somehow possible to "refresh" the translation to display the url fields?

Would be great if you can help me to solve this :)...

September 10, 2019 at 7:05 pm #4548429

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I could make the url field for the 'Bilder-box' Elementor module to appear editing the url field and saving it again. So, in order to 'refresh' your translations to show the url fields, please, make an editing for every url field of your image boxes in the default language, then update your translations accordingly. Please, let me know if it works for you, have a nice day.

September 11, 2019 at 8:39 am #4551767

Thomas

My issue is resolved now. Thank you!