Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 3 voices.

Last updated by Alejandro 1 year, 3 months ago.

Assigned support staff: Alejandro.

Author Posts
March 25, 2020 at 12:31 pm

Kristof

Elementor image URL not showing in Translation Editor

March 25, 2020 at 1:35 pm
March 25, 2020 at 2:57 pm
March 25, 2020 at 2:58 pm #5762003

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see my previous private reply and let me know once the migration is complete. Thanks!

March 25, 2020 at 7:44 pm #5763947

Kristof

Hi, I have migrated the site, however, I still see the default Cloudways index.php rather than our own homepage.

March 26, 2020 at 9:01 pm #5773831

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The landing page does look like that but I can confirm that the content migrated. I am continuing to translate there. I will update you as soon as I have more info.

March 27, 2020 at 3:21 pm #5780939

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for your patience while I continued troubleshooting. On the test copy of your site, I copied the page where this issue is happening. Here are the steps that resolved the issue for me. I recommend copying the page to test this first, as it may result in a loss of translated content. So it is likely you will need to re-enter the translated content for the page.

1. Go to WPML -> Packages and delete the package for this page ID. You can find which ID it is at the top of the translation editor box.
2. Edit the original page and update the custom URL
3. Now when you open the editor, you should see the custom URL fields.

Please let me know if this resolves the issue on your live site. Thanks!

Screen Shot 2020-03-27 at 11.07.13 AM.png
March 30, 2020 at 1:07 pm #5794821

Kristof

Hi Lauren,
I went to WPML -> Packages and deleted package "Page Builder Page 4535 - Contains 16 strings - Default package language: NL"
I then edited the NL Themawandelingen page. After that the update icons was visible for all languages. When I went into a translation, all Dutch strings were visible, luckily I saved each language as an Elementor Page Template.

HOWEVER, the urls that wrap the images still are not visible, see screenshot.
hidden link

March 30, 2020 at 9:52 pm #5799381

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Did you update the image URL? I just tested on that same page. I changed an image URL to hidden link just to test and when I saved the changes and opened up the English page in the translation editor, the new link was there.

Screen Shot 2020-03-30 at 5.50.25 PM.png
March 31, 2020 at 7:56 am #5801637

Kristof

Ok, I changed the url for the first image to Google and then indeed, the translation string becomes visible in the TE. But do I have to do this for ALL images? So first delete all packages (which means I will lose my translations) and then set all image urls to Google, save the page, translate, then go back to correct all Google links in the original Dutch language?

If this is the normal WPML way to translate image urls, I guess you've got some more development to do.

UPDATE 1: this issue is getting more and more complex, and frustrating.
As mentioned above, the English translation is now completely replaced by the Dutch language, luckily I had previously saved each Themawandelingen page in every language as an Elementor Page Template so I could quickly restore the page. So I opened the English page in Elementor, removed all Dutch sections and inserted my English Page Template, but when I look at the English translations via the Translation Editor, all Dutch strings are still there. So the Page is in English, the TE shows the Dutch strings.

UPDATE 2: after I have switched all Dutch urls from Google to the correct Themawandeling, the urls are once again invisible in the Translation Editor!

Screenshot_3.jpg
Screenshot_2.jpg
Screenshot_1.jpg
March 31, 2020 at 9:10 pm #5808029

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This is definitely not the regular way to translate, as you can see in the clean install the URL shows up without any problem and can be simply translated. As for the content not showing, please check one of the strings of text that you translated. Look for it in WPML -> STring Translation. Does it show there as needs update or not translated? If so, please translate or update. Then check the translation editor to see if the correct translation is both there and on the front end.

I see now on your site that the issue seems to happen with internal links. Try unchecking auto adjust IDs in WPML -> Languages. Also, did you ever run the Translate Link Targets in WPML -> Settings? I'm wondering if the URL is already translated somewhere and that is why maybe it's not showing? It's hard to tell because I am not able to reproduce the issue on a clean install.

April 1, 2020 at 11:30 am #5812461

Kristof

1. please check one of the strings of text that you translated
I have found TWO identical Dutch strings but with different Names and different Domains. I guess by restoring the translations via the previously built Elementor Page Template, the sync between the languages got lost, hence why Elementor shows the translated page and the Translation Editor does not.
I have now entered all translations via the Editor. Now title-heading-a570281 shows as Translation complete, while title-heading-55cc3e2d is still not translated, I guess that is an obsolete string. Can these be cleaned up?

2. Try unchecking auto adjust IDs in WPML -> Languages
I just unchecked this and saved the settings. The url strings still do not show up in the TE.

3. Also, did you ever run the Translate Link Targets in WPML -> Settings
Yes, I did that several times already.
I just searched for the exact string "hidden link" and got 3 results. Domain "elementor-4535" is my Themawandelingen page and Name "url-image-b93e72f" is indeed the corresponding image. The status is Translation complete.

Domain elementor-5263 is my Elementor Page Template "Themawandelingen - NL"
Domain elementor-3983 is my homepage

So do you have any idea on how to show the urls again, as indeed the status is Translation Complete. I used to see a checkbox show untranslated content only, but I am now missing this in the TE.

Screenshot_5.jpg
Screenshot_4.jpg
April 1, 2020 at 4:24 pm #5815853

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, i got this chat from Lauren since she's not currently available, so i hope you don't mind that i continue troubleshooting this issue.

I can see that indeed, you don't see the links translated and they don't show in the translation editor.

They should be translated automatically, actually, since they are internal links.

I'm checking and running a few tests on a clean installation again and on the migrated site, so this might take a while.

I had previously done something similar and it worked correctly, though, but i'd like to give it a try with this version of elementor and WPML, to see if this is indeed a bug or if it's a problem in the site.

I'll come back with an answer after i run the tests and i apologize in advance if it takes a bit longer than expected.

In the meantime i want to ask you something. you mentioned several times that you used to see the texts in the translation editor. could you please tell me if by any chance you had a previous version of WPML and/or elementor when you had everything working correctly?

Thanks in advance for the answer!

April 1, 2020 at 4:58 pm #5816199

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, i can confirm this is a bug and it will be fixed in the next release (which shouldn't take long).

I'll update you when it's live. in the meantime you can use a text block and add the image there instead of using the image widget, that should not have the problem.

Regards.

April 23, 2020 at 8:24 am #5974379

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!

Could you please update WPML and add-ons to the latest version you can see in: https://wpml.org/account/downloads/

The problem should be solved there already, but in order to "fix" it in your site you might need to:

- Update your title (you can add or remove a character to the title of the page that contains the widget, for example)
- Save the page
- Update the translation

Regards.