Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 10:00 – 14:00 8:00 – 12:00 8:00 – 12:00 10:00 – 14:00 -
- 14:00 – 18:00 15:00 – 19:00 13:00 – 17:00 13:00 – 17:00 15:00 – 19:00 -

Supporter timezone: Europe/Bucharest (GMT+02:00)

This topic contains 8 replies, has 3 voices.

Last updated by douglasF-4 4 years ago.

Assigned support staff: Mihai Apetrei.

Author Posts
January 15, 2019 at 8:36 am #3091335


I am trying to: keep Elementor inteface in English, whenever I edit a german translation.
In my user account, set admin language as editing language is disabled.

Instead, I got: Elementor in German...

January 15, 2019 at 8:48 am #3091454

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I have been informed by my colleagues in the dev department that this is the expected behavior and the way things work is: due to the fact that Elementor is a front-end editor, it uses the language of the front end, it does not matter what setting you choose, the Elementor panel elements use the same language as the language of the page you are editing.

Mixed strings issues are totally expected and it happens with other plugins, too (such as Cornerstone or Divi frontend builders).

The 'workaround' for this is to delete the translated strings and stop loading translations from .mo files (you can find out more about this here:

Kind regards,
Mihai Apetrei

January 15, 2019 at 11:07 am #3092428


Hi Mihai,

Thanks for your help.

So I set Elementor and Elementor Pro strings as "Not needed", and deleted these ones. Now the editor is in English indeed. However, what's gonna happen when if I upgrade my Elementor plugins. Will the translations strings be added again and translated ?

I also noticed that these plugins entries are again deletion. When I added the new language yesterday, we faced a huge increase of apache resources, and I suspect these 2 subjects might be related.

Is there a way to tell WPML not to translate plugins? I mean, of course I need to translate Gravity Form Fields, but I really don't need translating the admin interface values for any plugin, as we'll be perfectly fine with English only. That could drastically reduce the amount of listed translated strings, and database operations when adding a new language.

January 15, 2019 at 5:59 pm #3094293

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)


I am glad to hear that you were able to solve the issue.

Usually what WPML is doing is that it scans the plugins/themes that you are using and it adds the strings to the Strings Translation area. After you delete strings from there, they should not re-appear.

Here is a very helpful explanation and great steps needed to delete strings:

Hope that helps. 🙂

Please let me know if you still have questions regarding this.

I would be more than happy to help.

Kind regards,

January 22, 2019 at 1:49 pm #3116751


Honestly, that works, indeed, kind of... I still have paragraph styles translated in German, some buttons, admin bar, ... aand I checked this, all that stuff is queued as not translated in string translations right after I delete thmel, and will be translated again when I'll update Elementor.

Sorry, but once again, WPML is just a pain to work with.

January 22, 2019 at 6:42 pm #3117899

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)


Regarding the Elementor (and other content builders) interface language, unfortunately, that's the normal behavior.

From my understanding, there is also a different issue happening.

In our forum, we try to keep one issue per ticket.

Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

As the original issue is resolved may I kindly ask you to please mark this ticket as resolved and open a new ticket for the additional issue?

Also, it would be very helpful if you could provide more information like the exact steps you took to make the issue take place, screenshots, even links.

This will definitely help us in our debugging process.

Kind regards,


January 25, 2019 at 10:29 am #3128490


Let's say it's resolved...

January 30, 2019 at 3:41 pm #3144799


Sorry, but I thought again about this issue. I'm not sure I understand the purpose of this function so... What would happen if I un-tick the Element package in "Auto register strings translation", then delete the all the package translation stings ? Would it prevent the package to get translated from now on, even after Elementor get updated ?


April 8, 2019 at 10:09 am #3556427


I have the same issue... want to edit German pages using Elementor with English UI. I've done the same as above (I think) and here is a summary:

1. go to WPML string tranlation page
2. At the bottom, under Auto register strings for translation, I clicked edit and deselected elementor and elementor pro
3. back at the string translation page, search for all strings in elementor and elementor pro domains
4. select "display all results"
5. select all strings, click on delete strings

Hurray, now elementor UI is in English even when I edit a german page. I think and hope this should "stick" even after updating elementor, because of the unselect auto register strings for translation.

It would be great if WPML had an option to exclude specific plugins from translation. Also to delete those related strings from the DB automatically. I also noticed WPML does not delete strings from plugins that are deleted. Now that's just inefficient and wasteful. Does anybody like inefficient and wasteful things? 🙂