Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Elementor keeps loading when we have WPML enabled
Solution:
It was necessary to increase the WP Memory limit by applying the following code to the wp-config.php file:

define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Relevant Documentation:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
- https://wpml.org/home/minimum-requirements/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by ka-chuS 12 months ago.

Assigned support staff: Mateus Getulio.

Author Posts
October 1, 2020 at 5:21 pm #7146421

ka-chuS

I have the exact problem of this post https://wpml.org/forums/topic/elementor-stuck-on-loading-screen-if-wpml-is-activated/

My elementor keeps loading when WPML is activated like the attached picture.

I also prepared the debug.log file for your reference.
hidden link

Please help, thanks!

6764919-Screenshot_2020_08_09_at_21.57.22.png
October 1, 2020 at 8:01 pm #7147189

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked the error logs and found this: [01-Oct-2020 15:20:13 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32768 bytes)

This message usually indicates that you don't have enough memory on your WordPress install.

As WPML needs at least 256M to work smoothly and if your WordPress memory is bellow that mark, you may run into issues like this.

Therefore, it is advisable that you increase the memory limit to 256MB by adding this code to your wp-config.php, just before the line with “happy blogging” to check if this is just a performance problem in the backend:

define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

More info here:
- https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
- https://wpml.org/home/minimum-requirements/

Please let me know if the issue persists after adding the code above so we can see about our next steps.

Thank you.

October 2, 2020 at 3:11 am #7147737

ka-chuS

My issue is resolved now. Thank you!