This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Yvette 3 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
June 26, 2019 at 12:05 pm #4092273

olivierr-4

Hey when i duplicate a page, the elementor CSS layout is completely broken and some blocks are missing... i tried the solution proposed in this thread (Marcos Vinicios Barreto answer) but no luck : https://wpml.org/forums/topic/elementor-broken-layout-in-translated-site/

This is blocking my workflow and very annoying... could you help ?

thank you very much

June 26, 2019 at 4:09 pm #4094035

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´ll be helping you.

1. Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

2. Please provide an example of this that I can see. Ideally, it would be a simple page with basic content.

Thanks

June 27, 2019 at 4:08 am #4096511

olivierr-4

Hello i will send you all credential tomorrow, today i'm not at the office, thanky ou

June 27, 2019 at 7:35 am #4097273

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok - I´m opening the private area again for the information and the example when you are ready to provide it.

June 28, 2019 at 5:55 am #4104667

olivierr-4

Here you will have the example on page : compassion-app

the image : Capture d’écran 2019-06-26 à 13.59.32.png show the original page in french
the other image show the italian copied page after i did the translation process .

the page name is : Compassion App
the original langage : french
the secondary languages : german and italian

please note that i succeed to translate the german page last week after many tricks and trials

June 28, 2019 at 10:34 am #4106571

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I deactivated the Classic Editor plugin and I also enabled the WPML Translation Edito. With these two changes, when I then translated the page, the format was retained.

I have left the editor enabled. Please take a look for yourself.
hidden link

June 29, 2019 at 8:17 am #4111337

olivierr-4

Hello thanks for trying, could you please explain the exact process you did. Also i realised that since you touch the page, the column in my top section cannot be modified anymore. I try to enlarge at 100% and centerred but now the column is 25% of the widht and there's no solution to change the settings (before the column was 100% width centerred)... also could you explain why it was necessary to deactive the classic editor plugin, which i think caused the problem above (for all langs)... i think i'm done for now and i will find a solution myself... anyway thanks for trying

July 1, 2019 at 8:19 am #4116485

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. You asked: "... could you explain why it was necessary to deactive the classic editor plugin, which i think caused the problem above (for all langs).."

Answer:
I am not really sure if that was the issue, but I decided to eliminate the possibility of it interfering with the editing process. My suggestion is that you try a simple page and test the hypothesis just to be sure.

2. You wrote: "...i realised that since you touch the page, the column in my top section cannot be modified anymore.."

Response:
I am not sure what you mean - could you upload a screenshot of what column you are referring to? Or did you already find a solution?

July 2, 2019 at 6:34 am #4124317

olivierr-4

Hello i had to restore a backup because activating the WPML translation editor broke the elementor layout after investigating. as said, some section were no more editable and others had some strange behavior on page scroll... so... i think i will try other solution but i realise that WPML and Elementor are way not really compatible. Anyway thanks for trying.

July 2, 2019 at 7:38 am #4124725

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Alright - so we can close this ticket.

July 2, 2019 at 7:42 am #4124731

olivierr-4

Yes but it's a pity you didn't came with a solution... anyway i found a workaround by duplicating my page with a plugin and change the page language afterward... thank you again,

July 2, 2019 at 7:44 am #4124735

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Closing