This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by ivanK-23 3 weeks, 3 days ago.

Assigned support staff: Yvette.

Author Posts
June 2, 2020 at 6:07 am #6270277

ivanK-23

So i have bulgarian home page and english (main). The bulgarian is already fully translated. Or at least it was.

Link to a page where the issue can be seen: hidden link

I expected to see: When i enter the bulgarian page to see the bulgarian translation

Instead, I got: The bulgarian home page with english content.

More details: So this happend once before (month ago) when i entered the site in the morning and i saw that the bulgarian home page is in english. I thought that it is a onetime bug and i translated it in BG again (it took me around 2 hours). And today, just a few minutes ago when i entered the site the bulgarian content was overriden again with english. My first thought was a caching problem, but i checked - its not.

The core of this problem could be the same as my previous (Not Resolved for now) ticket : https://wpml.org/forums/topic/wpml-is-overriding-translated-attributes-with-the-default-language/ where i have the same problem but with the attrubutes.

Please help, I will not translate the home page in the next 2 days so you could see the issue. But after 2 days i will translate it becuse the bulgarian customers would be very confused when they enter the bulgarian version with english context. On the screen shots im providing you can see that only the menus have left in cyrllic alphabet (as they are external for elementor)

June 3, 2020 at 11:56 am #6283067

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1. Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

2. Is there any further configuration going on right now in this site?
3. Have you recently changed the kind of WPML Translation Editor that you are using? e.g. you changed from ATE to CTE, or CTE to ATE....¿
3. What about updates to plugins?

4. Are there any interfaces to the site from an external platform or application?

THanks

June 3, 2020 at 3:00 pm #6285129

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Thanks for access to your site, here are my observations:

1. Elementor Widgets
I can see that you are using unsupported widgets in the home page. Here are the list of Elementor widgets that are "compatible" with WPML and that are supported with our Translation Editor.
https://wpml.org/documentation/plugins-compatibility/elementor/#List-of-the-translatable-Elementor-Elements

As you can see, the list is very basic and does not include any of the Matfury widgets that you are using.

It is possible to ADD the support for these elements as per this tutorial but it will involve some coding:
https://wpml.org/documentation/plugins-compatibility/elementor/how-to-add-wpml-support-to-custom-elementor-widgets/

For now, I´ve turned off the WPML Transation Editor for this particular page. I would recommend now trying to use the normal WordPress / Elementor editor in the target language to make your translations manually.

After this is done - please monitor and see if the page mysteriously gets overwritten with EN content.

Thanks

June 4, 2020 at 8:21 am #6290991

ivanK-23

Thanks for the answer.
i will continue monitoring the issue.
Can you tell me how you turned off the Transaltion editor for this page, so i can know what to do for future issues on my other sites

June 4, 2020 at 8:38 am #6291113

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Of course!

1. Open the original language version of the object (page, post, ..etc)
2. Go to the sidebar "Languages > Translate this Document" section
3. Make sure there is "pencil" icon in "Translate" column for target languages. If you see a gearbox or circular arrow icon, then open and complete the translation before toggling the editor off.
4. Then toggle the WPML Transation Editor "off" (see image)
5. You will have option to apply the change to just that page, that post type, or site wide.

I hope this helps you.

June 8, 2020 at 6:24 am #6317561

ivanK-23

My issue is resolved now. Thank you!