This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Raja Mohammed 4 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 20, 2019 at 9:46 am #3845697

michaelv-23

I am trying to: edit the dutch and german version of the homepage

Link to a page where the issue can be seen: mudjeans.eu/?lang=nl (when logged in)

I expected to see: the page editable in Elementor (like before)

Instead, I got: either the error "no call to the_content" or the string translation screen for pages.

I can provide access if necessary.

May 20, 2019 at 10:05 am #3845881

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behavior?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Kind regards
Raja

May 22, 2019 at 8:19 am #3862897

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I need more information about the issue, Please perform some basic debugging and let me know the results

Before you proceed, backup your site and database.

- t would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

- Deactivate and remove WPML String translation and install a fresh copy of WPML string translation downloaded from https://wpml.org/account/downloads/

- Update the original page add some minor modifications check if you can edit the translations.

- Disable all Non-WPML plugins except the required theme and WooCommerce plugin check if the issue persists. if not try enabling the plugins one by one to isolate the issue.

Please let me know the results.

Kind regards
Raja

May 27, 2019 at 9:55 am #3895509

michaelv-23

I tried what you mentioned, the same issue persists with only these plugins:
- All WPML
- Woocommerce
- Elementor
- Elementor Pro
- ACF
- ACF Pro

I get no errors, only a warning: `[27-May-2019 09:52:49 UTC] PHP Warning: filemtime(): stat failed for hidden link in /var/www/commud-cilolohan/wordpress/current/wp-content/themes/mudjeans-child/functions.php on line 40`

But this shouldn't prevent Elementor from loading I think.

Let me know what we should try next!

May 27, 2019 at 3:34 pm #3899147

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for trying the steps,

Please perform this in a testing environment or after secure a backup of your site.
In addition to keeping only the required plugins active please change to any of WordPress default theme make sure Elementor is active, try to reproduce the issue. let me know the results.

If you are stuck please send me a snapshot copy of your site, You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/ I have enabled private fields for you to securely share the details.

Kind regards
Raja

May 31, 2019 at 12:44 pm #3930519

michaelv-23

Sadly our hosting provider can only allow 120 seconds of execution time and therefore we cannot do a backup through duplicator. Can you try on our staging environment? I already provided all the access you need there. We actually tested with only the plugins on that you suggested and the wordpress 2019 theme.

June 3, 2019 at 4:43 am #3939351

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

After following the instructions from the Elementor documentation hidden link and enabled the Editor loader Method from Elementor > Settings > Advanced, All the page loads in Elementor without any issues. It seems like your issue is resolved, Please verify the same at your end, Please let me know if you still need further assistance.

Kind regards
Raja