This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by pladosS 2 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 22, 2019 at 3:34 pm #4259575

pladosS

I am trying to:

Translate text within Elementor pages and templates, mostly headings, some text fields, standard Elementor things.

Link to a page where the issue can be seen:

hidden link

Homepage's strings have been "translated", kinda.

I expected to see:

Strings with text in Italian

Instead, I got:

Same as English

I have tried two ways to approach this:

The usual "+" and then add translations doesn't work properly. It only shows a bunch of images and if I complete translation from there all I get is a blank page.

The other way I have tried is to go to WPML > String Translation, I open the domain Elementor template I need to translate, such as Elementor-13481 (example number) and I translate lines from there.
This 2nd method doesn't show any change on the pages if I change the language, however.

If either method can get to work I'd be happy enough.

Thanks,

Michele

July 23, 2019 at 5:11 am #4262649

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

You should always try to use the first method, could you please follow the below steps and let me know if this helps:

1) Make the translation as complete (100%)
2) Now go to default language and update the post.
3) Send the post to translation again, this should show all the updated items.

Note: If the steps above don't work, I request you to add something dummy text on the default language and update both languages.

Let me know if this helps.

Thanks

July 23, 2019 at 8:31 am #4263905

pladosS

Hi,

I tried everything you suggested.

The 2nd screenshot is what I get right after I added another heading.

the first screenshot is the current Italian homepage, the result of the only things I get to translate and that I marked as done.

July 23, 2019 at 8:58 am #4264279

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To further debug this issue, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

July 23, 2019 at 11:27 am #4265591

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It seems like you are using elementor templates being so, could you please follow the steps to translate the template and let me know if this helps?
https://wpml.org/documentation/plugins-compatibility/elementor/#translate-elementor-templates

Look forward to your reply.

Thanks

July 23, 2019 at 12:17 pm #4265919

pladosS

That is the first method I wrote about, isn't it?

I press +, only the images are written in the translation manager and I don't have any string with my actual text translation, and the end result of me saving and closing is what comes out at the current it homepage.

July 24, 2019 at 11:22 am #4274035

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I tried to do the same way and couldn't find the strings in the translation editor but could found it in WPML->String Translation, I deleted the string from String Translation and tried again but the same problem appeared.

I tried the same on my test server and it's working. So could you please follow the below steps to narrow down the issue.

#1
Create a new template and try to translate using Translation editor. Sometimes when you use manual editors and translation editors for the same page this type of problem can happen.

#2
Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

#3
Could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Note: I have created a translation of that template in all language and deleted the strings from string translation to test the issue, so if you wish you can restore the previous settings from a backup and create a staging site to debug this issue further.

Look forward to your reply.

Thanks

July 24, 2019 at 12:18 pm #4274333

pladosS

I was doing tests as you said, enabled debvug, and I saw this pesky error on the debug.log:

WordPress database error Unknown column 'wrap_tag' in 'field list' for query UPDATE
etc.

Googling for that with WPML, I found out someone else has had that very same issue in the past, with Divi Builder:

https://wpml.org/forums/topic/wordpress-database-error-after-updating-wpml-unknown-column-wrap_tag-in-fie/

and that SQL query turned out to be what I needed to fix my issue as well. Now by going through normal translation manager I can translate pages and template isn't mangled.

Thanks for the help! Leaving this out in case anyone else needs it in the future.