We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Bigul 5 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
May 10, 2019 at 12:58 pm #3784409

markoP-7

Hello,

we made some pages with Elementor Pro and some templates and we inserted those templates into page (with the shortcode). We have also translated the template's content from slovenian to german (with classic editor). The problem is, that when we open the page in german, some style is gone, as you can see in the picture. We noticed that this happens only with the templates that are inserted into page. When we open the template in german it looks totally fine, but on the page (online) it looks like in the pictures. We tried to turn off all plugins expect Elementor and WPML and the "error" still remains.

Thank you!
Have a nice day.

May 10, 2019 at 4:15 pm #3786647

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Does it happen with Elementor Global Template? Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

I have a request. Please increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

--
Thanks!

Bigul

May 13, 2019 at 12:06 pm #3797849

markoP-7

Hello again,
we did everything you said, but the log file is empty.
We also increased the memory limit.
Any other idea what could be wrong?

May 13, 2019 at 2:12 pm #3799277

markoP-7

Our problem is solved. We changed all shortcodes to german ones and now it looks ok (previously we had slovenian ones with german translation).
Thank you for your help.

May 15, 2019 at 6:29 am #3812571

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Happy to know the issue is resolved now. Please feel free to contact us if you need any further assistance.

--
Thanks!

Bigul

May 15, 2019 at 7:02 am #3812839
markoP-7

Hello again... Yes, we solved our problem somehow, but we are not satisfied with the solution. We had to manually enter the shortcodes for another language. To do so, we had to edit the translation page with Elementor.

This is a big drawback because we cannot translate the page anymore (translation left-right) without losing functionality. When we do this old shortcodes are copied into translated page and we lose our styles. The only solution is to translate page directly - but this is no solution for me, because we could use other plugins for this like Polylang and it's free.

This part of WPML / Elementor integration is still not working and up to you to fix this. Please put this on your priority list and let us know when it's is done.

My suggestion how to solve this... WPML needs to find shortcodes for translated templates by itself and copy it into translated page instead of just copy original one which are not working.

May 15, 2019 at 12:20 pm #3816393

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please share me the URL of a couple of pages having this issue to reproduce it easily on your site.

--
Thanks!

Bigul

May 17, 2019 at 9:05 am #3832551

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marko,

Thank you for the staging site credentials. Sorry as per our support policies, we can only provide support via this forum. So the support via mail or video call is not permitted.

I will be opening new ticket for the Issue 2,3 & 4. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

I will work on it and get back to you soon. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

May 17, 2019 at 9:21 am #3832695

markoP-7

OK, i understand.

Some more info about WPML and losing style. The solution should also work if we change primary (default) language (switch with another language). When I edit the page in elementor, i should get shortcut number from selected language. Some info in case it helps you to find a solution.

Marko

May 24, 2019 at 10:07 am #3883281

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marko,

Thank you for the details to reproduce the issue. I can replicate it and the issue is escalated to our developers for fixing.

I am getting the expected in our test site while updating the German page manually with the German Template ID. Please try it as a workaround for the time being and let me know your feedback.

Please check the following URL and attached images for more details.

hidden link

--
Thanks!

Bigul

May 24, 2019 at 10:49 am #3883705

markoP-7

Hi!

We alredy tried it this way - to manualy edit the page in German. But this is bad solution (also for the time being) because the shortcodes is overwritten if someone translates the page using WPML. After we pass the website to our client, this could happen.

We found out that we could use tex editor and copy the code in it. Doing this whe code is visible in WMPL translation (left-right). But we need to do it manuly. For now it's the only solution, but later on I hope you can fix it to use the shortcode widget.

Marko

May 24, 2019 at 12:26 pm #3884665

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Marko,

Thank you for the feedback. We recommend using the text editor for translating the Shortcode, for example, while using shortcode like Contact Form 7.

We will get back to you soon when we have feedback on this from our developers. Please wait.

--
Thanks!

Bigul