This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.87 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:

An Elementor template that is placed as a shortcode into slider is missing the CSS in translations.

Solution:

When placing the template shortcode in the slide content area, WPML can not automatically replace it with the translation on the translated slide. So you would need to check the ID of the translated template and replace it in the shortcode on the Translation Editor. Please see the screenshot here.

https://cdn.wpml.org/wp-content/uploads/2019/07/4300471-correct_id.jpg?x34514

Relevant Documentation:

https://wpml.org/documentation/plugins-compatibility/elementor/#translate-elementor-templates

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by beth-el-industriesB 2 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 25, 2019 at 1:52 pm #4283821

beth-el-industriesB

Hi,
We use the great way of elementor templates inside of the elementor slides. For that we choose the main image in elementor slides and add the template shortcode in the content tab of the elementor slides.
This works great except in the second/additional languages. The position is different and the background color missing.
I read the thread about placing the template not via shortcode, but to my knowledge this is not an option in our scenario.
Can you help us?

July 25, 2019 at 2:47 pm #4284395

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Can you please tell me where I can see the issue on your site?
Please send me the link.
You also write: "I read the thread about placing the template not via shortcode"
Can you please send me the link to that as well?

Also, could you please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

July 25, 2019 at 2:55 pm #4284415

beth-el-industriesB

Hi Itamar,
thanks for your quick reply.
Our issue you'll see already at the added homepage: hidden link
The instruction how to use insert elementor templates together with WPML: https://wpml.org/forums/topic/css-for-elementor-template-is-not-copied-to-translated-page/

Please let me know, if you would like to have a wordpress access.

July 25, 2019 at 3:13 pm #4284621

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks.

Can you please explain to me why the solution that I've given to the other user at the following link, is not an option in your scenario?
https://wpml.org/forums/topic/css-for-elementor-template-is-not-copied-to-translated-page/#post-3892245

July 28, 2019 at 5:58 am #4294849

beth-el-industriesB

Hi, as you see in the attached screenshot, I have only the option to paste the template via shortcode into the slider content. Or did we miss a different solution?

thanks,
Benjamin

July 28, 2019 at 3:46 pm #4295621

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Benjamin.

It might be that your case is different. The other case was with pages, and you have a case with slides.
Could you please tell me the exact steps on how I can replicate this issue?
Please explain to me how you are creating the sliders and then inserting the template inside the slider. It would be helpful if you could write in steps. Do 1. 2. 3... and so on.

Thanks,
Itamar.

July 29, 2019 at 6:01 am #4297101

beth-el-industriesB

Hi Itamar,
Here our scenario:

• On a page I add the Elementor pro ‘slides’
• At the Slider content tabs I add per slide a background image.
• Inside of a slide at the ‘content' tab I add the templates short code (see screenshot from my last answer).

That’s it.

You’ll find a detailed explanation about this Slider/template combination here:
hidden link

July 29, 2019 at 1:53 pm #4300471

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Benjamin and thanks for the detailed explanations.

To try and see if I can replicate this issue, I've created a fresh WordPress installation. I've installed the latest version of the Elementor Pro plugin and configured WPML to have German as the default language and English as the second language, as on your site. Then I've followed the instructions that you gave me on how to create a slider with a template. And I also followed our instruction on how to translate Elementor templates.
https://wpml.org/documentation/plugins-compatibility/elementor/#translate-elementor-templates
Can you please confirm that you also followed our documentation on how to translate templates?
I can see that indeed when translating a page that has a slider the template shortcode from the slider's content area is showing as a shortcode. This is expected in this case. What I did was to add the correct ID for the English language. Please see the attached screenshot correct-id.jpg.
Did you also change the template id in the Translation Editor?

In any case, I was not able to replicate the CSS issue that you are having. But it might be that I'm missing some CSS configurations that you added.
Can you please confirm that the CSS issue that you are having is what I show on the css-issue.jpg screenshot?

You can see what I've created on my test site here.
German: hidden link
English: hidden link

As a workaround, I would like to suggest you edit the English translation of the template (not with WPML's Translation Editor) and add the missing CSS.

If needed, I would like to give access to my test site and ask you to try and replicate the issue if my above suggestion didn't help. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)

Thanks,
Itamar.

July 29, 2019 at 2:20 pm #4300797

beth-el-industriesB

Hi Itamar,
thanks a lot for your investigating in our problem.
It seems, that I missed the point of changing the template ID inside of the page translation into the English one. I was in opinion, that elementor will do this by itself.
Now it works perfect !

thanks,
Benjamin

July 29, 2019 at 2:26 pm #4300849

beth-el-industriesB

My issue is resolved now. Thank you!