This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 3, 2020 at 1:40 pm #5832667

simeaM

Tell us what you are trying to do?
I am building a site with elementor and woocommerce and wpml multilingual cms. As soon as I try to edit one of the Shop Templates (does not matter what language) it will stop showing. But also the header template stops showing in that case although the conditions are set correctly.

What is the link to your site?
hidden link

I already was in a chat with someone please reconnect me. Case Number #5831153

April 3, 2020 at 1:41 pm #5832669

simeaM

Please help!

April 6, 2020 at 6:17 am #5844613

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support again.

1.- Could you tell me if the issue persists on a minimal setup? Only WPML plugins active and a default WordPress theme, like Twenty Twenty?

2.- If you desire to keep getting assistance from the chat supporter, please open a new chat or provide the name of the supporter so he/she can manually take this ticket.

Kind regards,
Carlos

April 9, 2020 at 8:23 am #5873217

simeaM

The issue is resolved with another theme. However I am working with Elementor Hello (which is THE Theme when working with Elementor). Also, I have a Child Theme in use so that will not solve my problem...

2) I don't remember his name, it was a Chat-Support.

April 9, 2020 at 12:13 pm #5875905

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,
Thank you very much for your message.

There is a known issue with Elementor templates and conditions. Could you double-check if the conditions of the templates are only saved on the last language you saved them?

Regards,
Carlos

April 9, 2020 at 1:23 pm #5876341

simeaM

I always saved the Conditions always on the main Language Template. Is that an issue?

April 10, 2020 at 6:52 am #5881363

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

The issue is that when you translate the template to the secondary language and set the condition, it will overwrite the condition on the default language. If you then go back and edit the template in the default language, when saving the condition it will overwrite the condition on the secondary language.

I have seen this issue before and I just want to make sure if you are having the same problem. Could you test the steps above and let me know if it is what is happening on your site?

Regards,
Carlos

April 14, 2020 at 4:37 pm #5906649

simeaM

Oh I see, then I will do it that way.. Thanks.

April 14, 2020 at 4:38 pm #5906651

simeaM

My issue is resolved now. Thank you!

April 15, 2020 at 11:26 am #5912743

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos