This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 3 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
June 26, 2019 at 3:40 pm

christophS-41

Hi,

after installing WPML our templates (e.g. Header, Footer) just disappeared from the backend. It says there are 13 published templates, but you just can't access them.

If you try to edit the templates by clicking on "Edit with Elementor" in the frontend, there is an error message saying that there is no content on that page and that you have to access the "the_content" function.

June 26, 2019 at 8:23 pm #4095039

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please review our documentation about how to work with WPML and the Elementor Page Builder.
https://wpml.org/documentation/plugins-compatibility/elementor/
You also need to download and activate the Translation Management add-on which by looking at the debug information, I can see that is not active on your site.

Further please also correct the following. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Thanks,
Itamar.

June 27, 2019 at 7:57 am #4097467

christophS-41

Hi,

installed Translation Manager and increased Memory Limit. Templates are still not there.

June 27, 2019 at 4:52 pm #4101697

christophS-41

Wow, WPML now just messed up the whole site. I get 500 internal server errors for every page built in Elementor. This just can't be. Even after deactivating the plugins they stay like this.

June 27, 2019 at 5:52 pm #4101947

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry for what has happened on your site.

Could you please connect to your site with FTP and rename WPML and its add-ons on the /plugins/ folder?
This way we'll be sure that WPML is not active and be able to check if our plugins cause the issue. Here is what you need to do.

1. Log in to your site with FTP (alternatively, you can also log in to cPanel or similar and manage the WordPress installation from there).

2. Navigate to the /wp-content/plugins/ folder.

3. Rename our plugins (change their names. For example, you can add 'stop' in the beginning).
- sitepress-multilingual-cms
- wpml-string-translation
- wpml-translation-management

Does it help to solve the problem of Internal Server Error?

If you would like me to to do it for you, please share with me the FTP access details to your site. For this, I'm enabling a private message for the next reply.

Thanks,
Itamar.

June 27, 2019 at 5:55 pm #4101951

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

In addition to the above, you can also check if there are any PHP errors.

Please check this page for instructions if WordPress debug log is not enabled on your site.
https://wpml.org/documentation/support/debugging-wpml/
Look under the headline "Enabling the built-in debugging feature in WordPress".
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);.

Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.
If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

Please, could you provide me the additional Info?

Thanks,
Itamar.

June 27, 2019 at 6:19 pm
June 27, 2019 at 11:57 pm #4103215

christophS-41

Rebuilt the whole site. Problem "solved".

June 30, 2019 at 2:11 pm #4114273

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that the problem is solved now!

Could you please mark this ticket as resolved?

Thanks,
Itamar.