This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 10, 2018 at 2:53 pm #2720406

josianeF

I am trying to translate an Elementor page.

When I click on the + button & select copy existing page content so that I can have somehting to work with, what is copied is totally messed up. missing images & content...

September 11, 2018 at 7:52 pm #2725068

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Go to WPML -> Theme and plugins localization -> Scan the theme and the plugins related to Elementor.
- Flush any cache memory that might exists.
- Edit the page in the default language -> Make a small change -> Save it -> Duplicate the page in the secondary language -> Edit the page in the secondary language and set it as an indepent translation.

Could you tell me if the issue persists?

Also, I recommend you to visit this links where you will find our official documentation about this subjects:
- https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/
- https://wpml.org/documentation/plugins-compatibility/elementor/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 11, 2018 at 9:34 pm #2725352

josianeF

Thanks for getting back to me! It turns out I messed up with my setup and didn't install Translation string & the other plugin. Now I can see the Elementor translation interface. However when I switch to the secondary language, it gives me a 404 error. Page does not exist.

I tried everything you mentioned but it's still giving me the error.

I can give you access to the admin area if needed....

September 12, 2018 at 3:07 pm #2728026

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

Before providing access to the site I would like to ask you to create a new page and translate it. Does the issue persists?

Also, I kindly ask you to go to Settings -> Permalinks -> Re-save the permalink structure.

Looking forward to your answer.
Best regards,
Carlos

September 13, 2018 at 8:00 pm #2732845

josianeF

Thanks for your quick reply.

It seems to work when I create a new page & duplicate it. I've tried again to duplicate an existing page using the Translation Management Interface & editing it independently & it also worked.

However, when I don' duplicate the page it gives me a 404 error.

Is there a solution to this? I don't mind duplicating pages as I'm not building a content intensive site, but does this mean that if I add Elementor content to a page, I will have to manually add it to the translated one ? I'm not clear on the synchronization settings that apply here. Please clarify.

September 13, 2018 at 11:31 pm #2733262

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your message.

Elementor should be working with the Classic Translation Editor correctly. Could you double check if the Classic Translation Editor is selected in WPML -> Settings -> How to translate posts and pages?

Looking forward to your answer.
Best regards,
Carlos

September 17, 2018 at 12:01 am #2739212

josianeF

Alright, that option was already checked.

Here is my exact process: I go into Translation Management, check a page that I want to translate. Scroll down and check the translate checkboxes, add to translation basket...

Then go to Translations, find the page I just added and click on Translate. I am redirected to the Elementor translation interface. When I do my translation and save it, then go to the original page, then switch the language --> I get a 404 error.

Not sure why this is happening...

September 17, 2018 at 1:47 pm #2741219

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Could you tell me if you are the person who is doing the translation? Or there is someone else involved in this translation process?

Regards,
Carlos

September 18, 2018 at 6:11 pm #2746203

josianeF

Yes I am doing the translation

September 18, 2018 at 11:01 pm #2746683

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

In this case, as you are the person who is translating the content I recommend you to follow this steps:
- Go to Pages -> Edit the page you desire to translate -> Use the options in the right column under the Languages section to translate and/or duplicate the page, instead of going through the translation management interface.

Could you tell me if this solves the issue?

Best regards,
Carlos

September 26, 2018 at 1:05 pm #2767346

josianeF

Hi Carlos, sorry about the delayed response.

That''s actualy the first thing I tried. I translated the home page using this method but when i switch to French, it shows a 404 error...

September 26, 2018 at 8:09 pm #2768601

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

October 1, 2018 at 6:11 pm #2779147

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Before we start isolating the cause of this issue I would like to ask you to update all outdated plugins and themes to their latest version. Outdated functionalities can cause conflicts in the code.

Note: Please don't forget to create a full backup of the site before making any change for security reasons.

Best regards,
Carlos

October 6, 2018 at 2:52 am #2792360

josianeF

Hi Carlos, I just updated everything

October 8, 2018 at 12:07 pm #2795922

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for updating the plugins.

I took a deeper look at the site and the cause of the 404 error in French language is that the French version of the homepage was in the trash. I restored the page and now you can see it again.

Also, I applied some troubelshooting options and re-saved the permalink structure.

Could you tell me if the issue persists after the changes maded to the site?

Looking forward to your answer.
Best regards,
Carlos