Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 25 replies, has 2 voices.

Last updated by Osama Mersal 1 month, 3 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
April 8, 2021 at 10:13 pm #8496759

timoM-10

Tell us what you are trying to do?
We have a multi language page (ES/EN/DE) and work with Elementor. Blocks, that are used more then one time are saved as "template" and then added with the widget "Elementor Template. The problem is, that eventhough the block, that is associated with the widget, is already translated, only the main language will be shown. What must be done to get the translated block?

Thanks a lot for your help.

What is the link to your site?
You can find these blocks on our homepage: hidden link

screen03.png
screen02.png
scree01.png
April 11, 2021 at 7:54 am #8509269

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I’ll be glad to help you today.

1) Kindly check the translated template's name and try to change them. Then when using the "Elementor Template" widget, search for the new names.

If that didn't help, I would need to take a closer look at your site. So I would need to request temporary access (WP-Admin and FTP)
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private, which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme and to change configurations on the site if needed. This is also a reason the backup is critical.

2) It might not be related to the issue, but according to your Debug.info, the WP memory limit needs to be increased. PHP memory is fine, but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb. (Kindly check this page https://wpml.org/home/minimum-requirements/)

Add this to the top of wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Thanks for your cooperation

Regards,
Osama

April 13, 2021 at 3:06 pm #8526763

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for providing the access details. I'm not sure what causes this issue, but I have 2 suggestions. Kindly try them and let me know if one of them solved the issue.

1) Kindly go to WPML-> Settings-> Post Type Translation section, click on the lock icon beside Elementor templates and set it to "Translatable - only show translated items." (Kindly check the attached screenshot 1)

After that, update the Spanish home page and its translation.

2) The second suggestion is when editing the page using Elementor, make the section in a certain language, then edit the translation and make the section appears only on it. Kindly check the attached screenshot 2)

Kindly try these 2 suggestions and let me know if one of them solved the issue.

Thanks for your cooperation

Regards,
Osama

2.jpg
1.jpg
April 13, 2021 at 3:28 pm #8527043

timoM-10

Hello again, Osama.

Unfortunately, the first option doesn't work. 🙁 And the second option, I'm sorry but I didn't understand you quite complet...I've tried it, but it doesn't work too. Could you please explain it a little bit more in depth?

Thank you!

April 13, 2021 at 4:09 pm #8527631

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Sorry for the inconvenience. Allow me to explain my suggestion again. When you edit a page using Elementor and select a section, you would see a dropdown menu to select the language. (Kindly check the attached screenshot)

When you edit the Spanish page, select ES, save the page and check the English and German pages. You should not see the section.

Repeat the steps when editing English, select EN, and when editing German, select DE.

That might solve the issue and keep each section related to the correct language.

I hope this helps you. If you need further info, please let me know.

Best regards,
Osama

1.jpg
April 13, 2021 at 4:28 pm #8527731

timoM-10

Hello again, Osama.

Thank you for your answer. I'm sorry, but it doesn't work :(.

Please, check this thre links:

- hidden link
- hidden link
- hidden link

I've tried what you proposed me in this three cases with the Template of the red boxes. After doing what you said, I've updated the German translation with WPML and, sadly, the boxes are again in Spanish in the german site. The english link is still not updated, and that's because the texts are still in english in the site. Please, feel free to try the translation of the english site so you can see the issue.

Thank you!

April 13, 2021 at 5:10 pm #8527845

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the update. I have a last suggestion if it didn't work, I'd escalate this issue to our 2nd tier supporters.

Kindly go to the Elementor template from your dashboards and copy the template's shortcode, then edit the page and use the shortcode widget instead of the template widget. (Kindly check the attached screenshot)

When translating the page, type the shortcode on the search bar in the advanced translation editor and translate it by putting the translated template shortcode.

Thanks for your cooperation, I really appreciate it.

Regards,
Osama

1.jpg
April 14, 2021 at 11:52 am #8534733

timoM-10

Hello Osama,

Thank you very much for your time yesterday. We kind of get it with the shortcodes. 🙂

Now I have another Question to you, because I'm having a big problem with one of the sites.

Please check this site: hidden link and compare it with this one: hidden link.

The site was translated with WPML, like the other ones, but in this case the final result is not well displayed. You can check how the translation was done. Any suggestions about what could be happening?

April 14, 2021 at 12:06 pm #8535037

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Glad to hear that the shortcode suggestion did the trick. Regarding this page (hidden link), personally, I'd recommend that you duplicate the original page to the translations because it has a lot of options and complicated design, then edit the translations independently with Elementor and translate it manually.

Kindly check this guide to know more about manual translation. (https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/)

Kind regards,
Osama

April 14, 2021 at 12:15 pm #8535189

timoM-10

Thank you again for your answer, Osama. It has been very helpfull. Then, I should try it that way with this site.

If it's not a Problem for you, I would like to make you another question, and I hope this will be the last one.

Check please this site hidden link and compare it with this one hidden link.

Please, watch the second Slide. The three little paragraphs are not recognized by WPML, and I'm not being able to translate them. This happens in a few more cases around the Site, and I would love to get a solution...I can always, of course, go inside Elementor in the second or third language, but I would like to know if there's another option for this.

Thank you!

April 14, 2021 at 12:36 pm #8535411

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I've checked this page and found that you are using a widget that isn't a default Elementor widget (Kindly check the attached screenshot), so you might need to register this widget first to be able to see it in the translation editor.

Kindly check the following guides to know more about registering Elementor widgets:
1- https://wpml.org/documentation/support/language-configuration-files/how-to-register-page-builder-widgets-for-translation/

2- https://wpml.org/documentation/plugins-compatibility/elementor/how-to-add-wpml-support-to-custom-elementor-widgets/

As you said, the ultimate workaround for this issue is to edit the secondary languages using Elementor and edit the text manually.

Kind regards,
Osama

1.jpg
April 17, 2021 at 9:31 am #8560619

timoM-10

Hello Osama,

Thank you again for your time and dedication. I have one more question for you.

We have a Dropdown menu in our Top Menu Area, it is well setted in the WPML settings, but it is not working as a dropdown becaus it only shows the Languague we are seeing in that moment and does not give us the option of switching between the others.

I've been looking if we could have some CSS that could be hidding the rest, but I didn't see it. Any suggestions about what could be happening?

Thank you very much!

April 17, 2021 at 10:07 am #8560671

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I've checked the language switcher, and I think it might be a CSS issue to see what I'm talking about.

Kindly inspect the page, and you won't see the language switcher children items. (Kindly check the attached screenshot 1)

After that, set the language switcher to be in the Main Menu and inspect the page. You would be able to see the children items of the language switcher, but you would not be able to see the dropdown menu. (Kindly check the attached screenshot 2)

Finally, repeat the last step but set the language switcher to the footer menu. (Kindly check the attached screenshot 3)

However, if you set the language switcher to be a list, not a dropdown menu, it will correctly. So I think this might be a CSS issue.

Regards,
Osama

3.jpg
2.jpg
1.jpg
April 27, 2021 at 7:50 am #8631231

timoM-10

Hello Osama,

How are you? I hope that everything is going fine.

We are still struggling with some problems with the translation of our WebSite to German and English...

We've noticed that, when we translate a Site that has Elementor Global Settings, as a Table of Contents or Slide Anchors Name, or that just has some CSS code written in the global settings, it isn't translated to the new language. We have to change it manually...and this is a Problem for us because everytime we are making changes in the site and we refresh the translation some things like the anchor slide name (see attached) this changes are Overwritten...

We need to find a Solution to this kind of Problems, because this is not working good for us.

Thank You!

Captura-de-pantalla-2021-04-27-a-las-9.05.26.jpg
April 27, 2021 at 8:40 am #8631851

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I'm fine. I hope you are doing well. 🙂

In order to resolve this issue, you would need to set some Elementor custom fields to be copied. Kindly go to WPML-> Settings-> Custom Fields Translation section, click on "Show System fields".

After that, search for Elementor, and set the needed custom fields to copy. (Kindly check the attached screenshot)

Note: The lock icon means it's the default of Elementor, but you could click the lock icon to unlock the custom field.

I hope this helps you. If you need further info, please let me know.

Best regards,
Osama

The topic ‘[Closed] Elementor Widget "Elementor Template"’ is closed to new replies.