This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.60 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by Laura 8 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
December 29, 2018 at 4:00 am #3041697

arjenB-6

Switching between languages causes some Elementor widgets to change, specifically:

- Font size and color change after switching language (see image)
- A page heading background image's background-size property changes from "cover" to defaultI

I would expect Elementor widgets not to change after switching language. Can you help? Thanks.

December 29, 2018 at 11:43 am #3042041

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Could you tell me if the pages are first duplicated then translated or if are they directly translated?

December 30, 2018 at 3:02 am #3042896

arjenB-6

Hello Laura, thanks a lot for your reply. I've increased the memory limit but the issue still persists.

I _think_ the pages are directly translated, I'm not entirely sure how to know that.

December 30, 2018 at 3:34 pm #3043291

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you give me your credentials so I can better check the issue? Could you give me an example link where I can see the problem?
Is this a test site or a live site?

December 31, 2018 at 10:46 am #3044860

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

are you by any chance on Flywheel? I see an extra popup (see attachment) and the provided credentials don't work with it.

I'll enable another private reply.

January 2, 2019 at 10:34 am #3048602

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I did some checks on your site but I need to debug it further and since it's a live site I can't risk breaking it.

I sent you a private message just before this one with the instruction to create a copy of your site on a secure server, so I can test it freely.
Please let me know when it's ready so I can work on it.

January 9, 2019 at 6:18 am #3069822

arjenB-6

Dear Laura, thanks a lot for all the help so far. I have been out sick for the last few days and now I'm just catching up on this. I have followed your excellent migration instructions and the site migration is complete.

Just to reiterate, these are the issues I currently have when switching to any non-default language:

- Featured images disappear or their CSS properties change
(background-size: cover to background-size: default etc)

- Homepage: the yellow button and the secondary title heading don't show up in the translation editor (and thus can't be translated)

- Homepage: there is an image overlay on top of the video screen. Using a custom CSS media query, I remove this overlay on smaller screen sizes. On any other non-default language, this media query is missing.

- Text formatting changes with certain Elementor blocks (most notable the price table)

I'm looking forward to the next steps.

Thanks!

January 9, 2019 at 1:59 pm #3072019

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I still have to check everything but in the meantime, I can give you good news about the button on the home page.

If you go to WPML -> Strings Translation, you can find the button there and translate it. What I find strange it that the button is translated, but only in Dutch. Do you have an idea if the workflow changed at some point?

Edit: I found why. You button is in a global widget, and global widget are translated in Elementor -> My Templates, not in the Translation Editor.

January 9, 2019 at 3:56 pm #3072568

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

another update. It seems the CSS issue happens when you use the Translation Editor, if you just duplicate the page the CSS is correct.

I'm consulting with my colleagues to see which is the next step.

January 10, 2019 at 4:16 pm #3077023

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I found there is an issue with the "list price" widget in Elementor. At the moment it seems to be the only widget affected, I'm not sure your other CSS issues are related (it could be some kind of settings not copying over).

I escalated the ticket, I'll let you know as soon as possible.

January 24, 2019 at 11:21 am #3124707

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the issue should be fixed in WPML 4.2.0

January 25, 2019 at 1:41 am #3127377

arjenB-6

Thanks a lot for all your help. I will update from my end and if required, make a new ticket. Thanks again!

February 13, 2019 at 4:04 pm #3195244

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

WPML 4.2 is now released, can you confirm the issue is fixed?