Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 4 voices.

Last updated by DennisD 1 year, 5 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
April 16, 2018 at 9:47 am #1642512

DennisD

Hello, good day,
The issue is related to "Thank You Email String Conversion" basically the Danish language email contains English String, It must be the Danish only.

Following English strings coming in the mail
- "Your order is being processed" and "Thank you for the order" also please check this snapshot as evidence "hidden link".

here are snapshots of related settings
hidden link
also please check attached snapshot for another translation setting.

can you please provide me solution for the above!
Thanks waiting for your valuable reply.

April 16, 2018 at 5:51 pm #1650467

Ankit

Hi,

Thanks for contacting wpml support.

Could you please do following for me?

1. Delete the mentioned string from string translation table.

2. Go to WPML > Theme and plugins localization and scan woocommerce strings again.

3. Go to WPML > String translation and re-translate the mentioned string.

Please let me know if it helps.

Regards,
Ankit G.

April 17, 2018 at 10:48 am #1658993

DennisD

Hi,
I follow your provided steps:

1) I deleted the two strings from the string translation table
2) I re-scanned WooCommerce
3) I translated the strings again

But the texts in the email are still in English even if i have chose Dutch language while place order 🙁

Can you please provide solution to get rid of this issue!
Thanks

April 17, 2018 at 10:52 am #1658998

Ankit

I would request you consider providing me with temporary access (wp-admin and FTP) to your site in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply (See attachment). The information you will enter is private which means only you and I can see and have access to it.

April 23, 2018 at 11:26 pm #1778020

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

I would like to take care of your ticket from now. I did a test and the email looks like it was sent correctly. I'll attach an image for you to see.

I just clicked on WooCommerce > Settings > Email > Processing order > Save Changes, without changing anything.

Please, could you check if the email (subject and heading) is working properly?

Thank you.

April 24, 2018 at 6:50 am #1780338

DennisD

Hi Bruno,
Thank you for looking at it!
I'm surprised that it worked for you. I just tried again, but it's still the English texts:
hidden link

Hmmm, that's strange - any ideas

April 24, 2018 at 11:13 pm #1799341

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Have you tried with some other user to see if the problem persists? Maybe you can use this account you created for us to test.

I tried again and the email was sent correctly. I tested with a logged in user (using the credentials you posted) as well as with a new user as if he were making the first purchase. Both emails were sent correctly.

Please, could you test with a new user or with a different email to see if the problem persists?

Thank you.

April 25, 2018 at 7:53 am #1803598

DennisD

Hi Bruno. Could you enable the private reply?
Then I'll share a video with you, where I am testing it. Still getting the un-translated text. But I am actually not logging in. Just making an order as a "guest" user.

April 25, 2018 at 10:30 pm #1820653

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sure. Your next message will be private.

Thank you.

April 27, 2018 at 1:41 am #1847975

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thanks for the screencast. I see the issue you're reporting. I was testing with another payment gateway and so I was not seeing the problem. And then, manually converting the product to processing, directly from the backend of WordPress.

The problem seems to be happening only in automatic email sending. Manually this works correctly.

Is this data you use on your site, such as your credit card number, test data? Can I use these same numbers to test?

Thank you.

April 30, 2018 at 7:44 am #1890864

DennisD

Yes, you can see this test cards on this page:
hidden link

You can use the first card listed for testing.

May 1, 2018 at 4:14 am #1908023

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I was able to replicate the problem you are reporting. I will contact 2nd tier support and soon we will contact you.

Thank you.

May 2, 2018 at 12:24 pm #1931217

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry for the delay.

I forwarded your email to our 2nd tier support team. The 2nd tier support will check your ticket and this issue and soon we will contact you.

Thank you.

May 11, 2018 at 6:04 pm #2093269

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from the second tier support team.

So as I understand that the issue happens when the request comes from the QuickPay site, so in order to be able to debug the issue, can you please contact the QuickPay support and ask them if they can send us the URL which they call after completing the payment process and which is responsible for sending the processing order email to help us debug the issue.

Our compatibility team has tried to contact them before but they haven't replied, so please contact them and ask them if they can send you this URL to expedite the debugging process.

The next reply will be private in case you want to share any sensitive data.

Best Regards.

May 18, 2018 at 2:57 pm #2189918

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks, I will check it and let you know.