This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by valentineB 12 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 7, 2018 at 8:28 pm #2794307

valentineB

I am trying to: Access images from media gallery

Link to a page where the issue can be seen: hidden link

I expected to see: Uploaded images in my media gallery

Instead, I got: An empty media gallery

October 8, 2018 at 3:01 pm #2796526

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Did you get the chance to install WPML Media and duplicate the media for translation yet? I'm asking this because I don't see the WPML Media plugin installed on your site at the moment.

Please follow these steps and let me know if at the end, you can see the images back in the media library:

- Go to https://wpml.org/account/downloads/ (log in first)
- Download the "WPML Media Translation" plugin
- Install the plugin into your WordPress setup (documentation on how to install plugins manually in WordPress here: https://codex.wordpress.org/Managing_Plugins#Manual_Plugin_Installation)
- In the WP Dashboard menu, go to the WPML -> Settings -> scroll down to the "Media translation" section
- Make sure the "Translate existing media in all languages", "Duplicate existing media for translated content" and "Duplicate the featured images for translated content" boxes are checked
- Click Start.

After following these steps, please test with both default and secondary languages (switch them from the top of your WP dashboard) to check if the images are now showing in the media library for the languages.

Here is also the documentation on how to use the WPML Media Translation plugin:
https://wpml.org/documentation/getting-started-guide/media-translation/

I will be waiting for your response.

Please let me know if this helped you accomplish what you needed.

October 9, 2018 at 12:25 pm #2799920

valentineB

Hi and thank you for your answer.

I have tried to follow the steps described in your message but I couldn't complete them unfortunately.
Everything is OK until I click "Start". The displayed wheel then turns forever (I let it turn during more than 10h last night) and nothing else happens (see uploaded picture for more details).

Thanks a lot for your help.

October 10, 2018 at 6:10 pm #2805403

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Let's try these steps, too, before clicking on "Start" once again:

- Go to the WP Super Cache plugin settings and clear/delete all the cache
- Go to the Plugins page and disable WP Super Cache for the moment

Please try to click the blue "Start" button once again after following the steps above.

In case it will still not work (even if it might work), there's also something else we would need to consider.

I was able to do a few more tests and I found that for the moment your site is using an outdated version of MySQL on your server.

The minimum required version is MySQL version 5.6 (and above) so I will need you to update the MySQL version to at least v5.6 (an admin of the server can do that usually or the hosting company).

Here you can find the list with the minimum WPML requirements:
https://wpml.org/home/minimum-requirements/

So if it won't work after the first 2 steps, please have the MySQL version updated and then try to click again on the blue "Start" button.

Please let me know how it goes and if this solved your issue or if you still need help.

I will be waiting for your reply.

October 15, 2018 at 8:31 am #2816597

valentineB

Hi,

Thanks for your answer. I have cleared the cache and deactivated the cache plugin but media still don't appear in the gallery.

My website is hosted on a shared environment, I cannot modify the mySQL version by myself. I have asked the hosting company to do so. I am still waiting for their answer.
Meanwhile, could you please leave the ticket open ?

October 15, 2018 at 5:07 pm #2818388

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Sure, I will leave the ticket open.

Please let me know when you have more information about this.

Kind regards,
Mihai

October 15, 2018 at 6:19 pm #2818526

valentineB

HI,

Unfortunately, my DB is hosted on a shared environment and mySQL 5.5 is the maximum version I can have access to. The hosting company is pretty big in France though (OVH) and a lot of WP website are hosted there on shared environments. I cannot believe all of them have the same kind of trouble with WPML.

I have checked on google, apparently the mysql version has an impact on performance but should work with WMPL.

Would you have any other solutions I could try please?

Otherwise I will have no other solution than resigning my WPML subscription.

Thanks.

Kind regards

October 16, 2018 at 4:51 pm #2821893

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Let's also try this:

❌ Before proceeding please make a full website backup! ❌

Go to WPML -> Support -> Troubleshooting

Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix terms count"
• "Fix post type assignment for translations"

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

October 18, 2018 at 8:39 am #2827196

valentineB

Hi,

Unfortunately, I could not complete all the steps described above. Everything seems to be working fine until the last step : "Fix post type assignment for translations".
When clicking the button, the wheel starts spinning but never stops (I let it spin for more than 4 hours).

Would you have any other ideas please?

Thanks and kind regards

October 18, 2018 at 5:36 pm #2829055

valentineB

The problem came from WP install corrupted files and clean install solved it all.
My issue is resolved now. Thank you!