This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Andreas W. 4 months ago.

Assigned support staff: Andreas W..

Author Posts
May 30, 2019 at 2:51 pm #3923997

radekT

Please, how can I achieve, that fusion_flip_boxes attribute image will stay empty in translated page?

WPML's Translation Editor replaces: image=""
with: image="hidden link"

This causes that Avada/Fusion Builder think that the image attribute has value and this causes incorrect behaviour.

The code generated by Fusion Builder is: [fusion_flip_boxes columns="1" icon="" icon_color="" circle="" circle_color="" circle_border_color="" icon_flip="" icon_rotate="" icon_spin="no" image="" image_width="" image_height="" hide_on_mobile="small-visibility,medium-visibility,large-visibility" class="FlipBoxIconsAsBackground" id=""]

But when the code goes through WPML's Translation Editor, the attribute image is filled with value of path: [fusion_flip_boxes columns="1" icon="" icon_color="" circle="" circle_color="" circle_border_color="" icon_flip="" icon_rotate="" icon_spin="no" image="hidden link" image_width="" image_height="" hide_on_mobile="small-visibility,medium-visibility,large-visibility" class="FlipBoxIconsAsBackground" id=""]

This is incorrect part: image="hidden link"
It should be: image=""
---
WPML configuration file from hidden link contains this definition of image attribute:
<shortcode>
<tag>fusion_flip_boxes</tag>
<attributes>
<attribute type="media-url">image</attribute>
</attributes>
</shortcode>
<shortcode>
<tag>fusion_flip_box</tag>
<attributes>
<attribute>title_front</attribute>
<attribute>title_back</attribute>
<attribute>text_front</attribute>
<attribute type="media-url">image</attribute>
</attributes>
</shortcode>

I have copied the file hidden link into hidden link and resaved the page hidden link. But I don't see any change in the code. Attribute image still contains the path.

Please, how can I achieve, that fusion_flip_boxes attribute image will stay empty in translated page?

Or may you point me to the script that is responsible for parsing the image attribute of type media-url? Is it possible that I have configured something somewhere and this causes the problem?

Thank you

May 30, 2019 at 4:56 pm #3925201

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

You can use the following values:

ignore-content – Can be used within in a tag element. This value is optional and it can be either 0 or 1. You can use this attribute to achieve backward compatibility for new media shortcodes. If the value is set to 1 the shortcode content will not be processed.

Example:

<wpml-config>
<shortcodes>
<shortcode>
<tag ignore-content="1">fusion_flip_boxes</tag>
<attributes>
<attribute type="media-url">image</attribute>
</attributes>
</shortcode>
<shortcodes>
</wpml-config>

https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Let me know if you need any further assistance.

Kind regards
Andreas

June 3, 2019 at 11:38 am #3941961

radekT

Hello,

fusion_flip_boxes shortcode should be processed, but correctly.

Empty value of image should not be replaced with path to uploaded images.

June 3, 2019 at 3:46 pm #3943975

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 4, 2019 at 11:36 am #3951091

radekT

Are you OK with this?

June 4, 2019 at 4:12 pm #3953595

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The ignore-content can only be used on the shortcode tag. This might be the reson why it is not working with the attribute image only.

The proper workaround here would be to to edit a blank space and mark the field as translated.
You can revise this on the following sandbox:

One Click Login: hidden link

Let me know if you do have any questions.

Kind regards
Andreas

June 4, 2019 at 4:32 pm #3953671

radekT

Hello Andreas,
thank you for link to sandbox. I did test it at:
* hidden link and
* hidden link

and see it works.

But I do not understand, what you mean with: "The proper workaround here would be to to edit a blank space and mark the field as translated."

I don't see the "blank space" at hidden link

Nor I don't see "" (blank space) at hidden link

Please, can you send me a printscreen of transaltion of blank space?

June 4, 2019 at 4:58 pm #3953879

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry but I can not follow. Your test pages does not include any image inside the flip box. As far I understood you wish to add a image in default language and avoid that this image gets copied to the translated page, correct?

With blank space I mean the spacebar. It is simply not possible to visualze that. I added an image to the original page and when translating the image inside of the WPML TranslatioN Editor I entered nothing into the translation field than a hit on the spacebar. This makes the filed think that an entry was made an you will be able to mark the translation as completed.

Let me know if you do have any further question.

Kind regards
Andreas

June 4, 2019 at 5:06 pm #3953923

radekT

Hello,

you wrote: "As far I understood you wish to add a image in default language and avoid that this image gets copied to the translated page, correct?"

No. I do use icon in default language. So default language attribute image is empty. I wish to have empty also translated attribute image. But the translated attribute image isn't empty, but "hidden link"

June 4, 2019 at 6:20 pm #3954389

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am really sorry but I think I still do not understand the issue.

You created a flip box and selected an icon, then translated it. The translation does include the same icon. This icon is based on the Avada Theme Option.

You wish that this icon will not appear on the translation?

Kind regards
Andreas

June 4, 2019 at 6:28 pm #3954513

radekT

Hello,

I wrote, what I want at the very beginning: In translattion, the attribute "image" should have value "", not "hidden link"

This is because of the logic inside Avada. If attribute image is empty, it displays icon. Iv the attribute image is not empty, it tries to display the image (instead of icon).

June 4, 2019 at 6:44 pm #3954705

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please provide me some screenshots to visualize this issue to our second tier?

Are you refering ot the option icon image?

Kind regards
Andreas

June 4, 2019 at 8:00 pm #3954997

radekT

Hello Andreas,

thank you that you continued support without my need to create copy of production environment.

1) Please see attached files:
1a) empty-attribute-image-replaced-with-path-fusion_flip_boxes.png
1b) empty-attribute-image-replaced-with-path-fusion_flip_boxes-invisible-problem.png

1a shows, that if icon is used, the problem is visible both in administration/source and in front-end
1b shows, that if real image is used, the problem is visible only in administration/source code

2) I now found, that this is very probably the same problem as I reported in https://wpml.org/forums/topic/shortcode-fusion_content_box-empty-attribute-image-is-translated-incorrectly/

Please see attached file empty-attribute-image-replaced-with-path-fusion_content_box-with-comments.png

June 4, 2019 at 8:08 pm #3955069

radekT

The workaround that I do:
1) I do edit the page in default/source/Ukrainian language. I remove all the texts: image="" and save the page
2) I do reload the translation (in Russian) and save it.

After this, the attribute image is not present nor in Ukrainian nor in Russian version - and the icons do correctly display.

June 5, 2019 at 4:19 am #3957035

radekT

Hallo,

I just found, that 2 revisions are created, after I press button "Save" in WPML's Translation Editor:
* first revision saves correctly: image=""
* second (immediatelly auto created) revision replaces correct value of image with: image="hidden link"

I do attach printscreen of this.

The topic ‘[Closed] Empty media-url is replaced with image=";’ is closed to new replies.