Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 4 voices.

Last updated by Carlos Rojas 2 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 11, 2019 at 11:22 am #4189229

Maximilien HAIBI

I am trying to: sync empty sales price, i want to remove sale price but not syncing to other language, working fine with main language

Link to a page where the issue can be seen: hidden link

I expected to see:hidden link

Instead, I got:hidden link

July 11, 2019 at 11:49 am #4189417

Maximilien HAIBI

I seen similar thread https://wpml.org/forums/topic/wpml-price-variation-sync-issue/

Is there any easy temporary solution ?

Thanks

July 11, 2019 at 2:00 pm #4190551

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

To solve this issue I would like to ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code.
- Flush any cache memory that might exists.
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix any error that might appear.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options -> Click on 'Start' button.

Could you confirm that the issue is solved after the steps above?

Kind regards,
Carlos

July 12, 2019 at 6:12 am #4195439

Maximilien HAIBI

Thanks Carlos for your quick reply,
I follow your instruction, but still issue not resolved.

- Create a full backup of the site.: Done
- Update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code. : WordPress, themes and plugins are up to date
- Flush any cache memory that might exists. : Clear Cache
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix any error that might appear. :No error, See screenshot
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options -> Click on 'Start' button. : I did troubleshooting for "Fix translated variations relationships" its complete and when i reload page it's again showing 3571 left, seems its not fixed, See attachment

My customer is in worry, can you please help me to fix this issue ASAP, Your help would be much appreciated.
Many thanks,

July 12, 2019 at 1:21 pm #4199281

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for your message.

It's normal that when you reload the page in Woocommerce -> Woocommerce Multilingual -> Settings -> Troubleshooting the numbers appear again, this is not a sign of something wrong.

If you see that the issue persists then I recommend you to follow this steps:
- Backup the entire site
- Flush all cache memory.
- Deactivate all plugins except WPML plugins, Woocommerce and Woocommerce Multilingual.
- Activate a default WordPress theme like Twenty Nineteen.
- If the issue persists sync the products again in Woocommerce -> Woocommerce Multilingual -> Settings -> Troubleshooting
- Go to WPML -> Support -> Troubleshooting link -> Apply the steps pointed out in the attached image.
- If the issue disappeared then activate the theme and the plugins one by one until the issue appears.

Could you tell me the result of the steps above?

Regards,
Carlos

July 16, 2019 at 6:59 am #4216743

Maximilien HAIBI

Hello

I follow above steps, could not fix problem

- Backup the entire site : Taken
- Flush all cache memory. : Disable cache plugin
- Deactivate all plugins except WPML plugins, Woocommerce and Woocommerce Multilingual. :
disable all plugin exclude woocommerce and wpml plugins

- Activate a default WordPress theme like Twenty Nineteen. : disable divi theme and active Twenty nineteen theme

- If the issue persists sync the products again in Woocommerce -> Woocommerce Multilingual -> Settings -> Troubleshooting > checked all checkbox and sync

- Go to WPML -> Support -> Troubleshooting link -> Apply the steps pointed out in the attached image. > Did mention action as attached screenshot

Still Issue not resolved,

What to do next, I really need to fix today,

Thanks

July 16, 2019 at 10:06 am #4218801

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

July 18, 2019 at 3:30 pm #4240195

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for the information provided.

Before we continue I need to ask you to update all outdated plugins and themes. Outdated functionalities can cause conflicts in the code.

Note: Please don't forget to make a full backup of the site before any change.

Could you tell me if the issue persists after updating all plugins and themes?

Regards,
Carlos

July 19, 2019 at 4:34 am #4243819

Maximilien HAIBI

Hello,

I have update theme and plugins, Everything is up to date.

issue still persist

Thanks

July 19, 2019 at 12:42 pm #4246503

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Dev,
Thank your for your feedback.

I deactivated all plugins except WPML plugins and the issue seems to have disappear. Could you double check if the issue disappeared?

If this is the case then start activating the plugins one by one until you see the issue appear again.

Regards,
Carlos

July 19, 2019 at 1:03 pm #4246621

Maximilien HAIBI

Hello Carlos

Seems you didn't get with issue,
See video i have attached, See action i did from 22 second to 30th second
hidden link

I am setting blank sales price, You see? And Save

It's work for Default language but not work for other language as It's doesn't sync.

If I enter some amount instead of blank then It's sync to all language and works.

Thanks for your quick reply

Regards,
Dev

July 19, 2019 at 3:29 pm #4247141

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Dev,

I think I have found the cause of the issue, however I'm not 100% sure yet. Please follow this steps:
- Open the Javascript console of the browser.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select 'Sync product stock quantity and status ( synchronizing min stock between translations )' -> Click on 'Start' button.

You will see a JS error related to admin-ajax.php and I suspect this is the cause of the issue.

Could you fix this issue?
Regards,
Carlos

July 22, 2019 at 5:20 am #4254041

Maximilien HAIBI

Hello Carlos

I checked for that console error, It's because of "PHP message: PHP Fatal error: Allowed memory size of 134217728 bytes exhausted" error, I increase memory limit, Now console error is fixed,
hidden link

But still issue not resolve,

Thanks,
Dev

July 22, 2019 at 12:09 pm #4256957

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Dev,
Thank you very much for your feedback.

I think I have found the cause of the issue. It seems that WPML doesn't fetch the action of changing the sale price for all variations. However if you follow this steps you should be fine:
- Edit the product in French (default language) -> Set the sale price for all variations -> Select the first variation -> Set a different sale price -> Save the variations -> Go back to the first variation and set the right price -> Save the changes -> Save the product.

I suspect that WPML is only fetching the action of saving changes of the blue button at the end of the variations section.

Could you tell me the result of the steps above?
Regards,
Carlos

July 23, 2019 at 4:52 am #4262627

Maximilien HAIBI

Hello Carlos

Seems you still didn't get with our actual issue. 🙁

It's working fine when we enter some sales price, But getting issue when we want to remove sales price.

We could not set empty sales price.

Issue is when we set empty sales price, It's work fine in default language but It doesn't sync to other language.

Can you please suggest definitive solution ?

It's really headache to remove sales price from database.

Thanks,
Dev