Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Tim 1 year, 6 months ago.

Assigned support staff: Osama Mersal.

Author Posts
December 30, 2020 at 1:29 pm #7754597

Tim

On Spy-fy.com we are using Woocommerce, wpml and woocommerce multilingual, last weeks we have encountered a issue where the products are randomly disappearing from every shop page, right now we have to manually check the shoppages every single day for this issue, most of the times we can fix it by saving the permalinks again but we would really like to get some support on how we can fix this permanently.

December 30, 2020 at 4:38 pm #7755439

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML support forums. I’ll be glad to help you today.

I can see that the shop in the original language (hidden link) is showing no products. Could you please answer the following question to help me understand the issue more:

1- How frequently this issue happens? And if there any symptoms before it?

2- why do you think that WPML or WooCommerce Multilingual causes this problem?

3- Did you try to deactivate WPML and see if the products disappear from the shop page or not? If not, could you please try this? *Kindly take a full backup of your website before trying this*

Thanks for your cooperation

Best regards,
Osama

December 31, 2020 at 8:21 am #7758835

Tim

Hello there,

This issue happens almost every day / 2 days right now and as far as i know nothing happens before this issue.

It was my first guess that it might had something to do with woocommerce multilingual because when it happens there is always one language that doesn't have the issue

I deactivated every wpml plugin when the issue happened and the product were still gone.. I fixed it for now by resaving the permalinks and clearing the cache, could it be that at one point Woocommerce + wpml "doesn't know" which product belongs to which language and because of that it shows there are no products?

December 31, 2020 at 12:05 pm #7759737

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your cooperation. Could you please tell me the default language of your site when you deactivate WPML? and whether you changed the site’s default language at any point after installing WPML and configuring the custom language?

Could you please confirm that you followed this doc (https://wpml.org/documentation/related-projects/woocommerce-multilingual/#translating-product-categories-tags-attributes-and-custom-taxonomies) to translate your products taxonomies?

Could you please provide me with the WordPress debug.log. Please check this page for instructions (https://wpml.org/documentation/support/debugging-wpml/)

Look under the headline “Enabling the built-in debugging feature in WordPress.”

To enable it, open your wp-config.php file and look for
define(‘WP_DEBUG’, false);.

Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

In this case, after causing the problem to occur again, the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

Best regards,
Osama

January 8, 2021 at 7:55 am #7799041

Tim

Heya,

Giving an update, i didn't had the issue last couple days so i'am unable to generate the log for now, monitoring it every day for now to see if it still happens

January 10, 2021 at 7:30 am #7808677

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hello,

Sorry for the late reply. Please take your time to debug, and get back to us when you generate the log. We are always happy to help you.

January 11, 2021 at 8:05 am #7813251

Tim

Hi Osama, No problem!

Today the issue happened again sadly.. I have pasted the debug log into pastebin and you can check it here https://pastebin.com/W5mBpzmK

Also would like to inform you that i fixed it this time by resaving the permalinks and clearing the cache.

January 11, 2021 at 12:51 pm #7816135

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Tim,

Thanks for providing the log. Currently, I'm consulting 2nd tier supporters, and I'll let you know if I get any updates.

Thanks for your patience.
Osama

January 12, 2021 at 4:56 pm #7827797

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Tim,

I would need a site snapshot if possible. We usually recommend the free Plugin “Duplicator” for this porpoise.

If you already know how Duplicator works, please skip the following steps and send me the installer file and the zipped package you downloaded.

If you don’t, kindly check this page. (https://wpml.org/faq/provide-supporters-copy-site/)
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to log in. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so that you can provide me the information securely.

Thanks in advance
Osama

January 17, 2021 at 8:16 am #7861789

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hello,

Sorry for the late reply. Thanks for providing the package.

I'll work on the issue, consult 2nd tier supporters, and get back to you when I get any updates.

Thanks for your cooperation and patience

Regards,
Osama

January 20, 2021 at 12:49 pm #7887423

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Tim,

Thanks for your patience, we are running your copy of the site on our local server, but we didn't face this issue.

Could you please tell me if you are still facing it?

Thanks,
Osama

January 21, 2021 at 7:37 am #7893983

Tim

Hello there!

The problem didn't happen always, even for us it didn't happen the last couple days so it might be fixed by now

January 21, 2021 at 7:39 am #7893989

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the update

Regards,
Osama

January 27, 2021 at 11:00 am #7939699

Tim

Hello there! The last 2 weeks the problem didn't happen anymore so i guess its fixed 😀 only real thing that has changed is that we moved the website to WPEngine.
Thanks for the help!