Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bigul 1 year, 10 months ago.

Assigned support staff: Bigul.

Author Posts
January 24, 2019 at 12:50 pm #3125087

svenA-8

Tell us what you are trying to do?

In plugins am getting message "For String Tracking to work, the option Assume that the original language of all strings is English was automatically disabled. To enable it back, go to WPML->Theme and Plugins localization."

When trying to do what is suggested (not knowing why?) am getting message that cannot save ? Is this critical or what is the issue really ?

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

January 25, 2019 at 6:06 am #3127963

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Please let me know the following details to track the issue.

1) It happens rarely when English is the not the default language of the site. So which is your default language

2) Please visit WPML>>String Translation and check you are enabled *Track where strings appear on the site* feature or not

3) To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

January 25, 2019 at 8:03 am #3128080

svenA-8

Hi Bigul,

Thanks

1) English is and should be default language
2) Done

My question remains though why we're doing this. What is the end goal. Still unclear to me

January 25, 2019 at 1:03 pm #3128939

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It requires further checking. So please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

January 28, 2019 at 10:30 am #3134919

svenA-8

Thanks. Have made a backup.

Not sure of next steps here as failing to understand the process.

Thanks again in advance for your assistance

January 28, 2019 at 6:02 pm #3137133

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I am enabling the private option for the next reply. Please share me the credentials to access your site backend for further checking of the issue.

--
Thanks!

Bigul

January 30, 2019 at 9:05 am #3142798

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. I have checked with our second tier team about this issue. Most probably you are getting this notification because you have enabled *Track where strings appear on the site* feature of WPML>>String Translation. Usually we will not recommend enabling this feature because of the performance issues.

So please disable *Track where strings appear on the site* feature and check you are still having this notification or not.

If you are still having the issue, please choose Assume that the original language of all strings is English option of the WPML>>Theme and plugins localization>>Localization options>>Other options: and make sure you still having the notification or not.

--
Thanks!

Bigul

January 30, 2019 at 9:53 am #3142964

svenA-8

Hi Bigul

Have now disabled *Track where strings appear on the site*. Then went to choose "Assume that the original language of all strings is English" (tick in the box) but still same message flashes "data not saved". Don't know now why at what all this means in the end all honesty?

January 30, 2019 at 5:57 pm #3145268

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please share with me the WordPress debug.log(not WPML debug information) for more details. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

The topic ‘[Closed] Enabling "Assume that the original language of all strings is English"’ is closed to new replies.