This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
December 4, 2018 at 2:50 am

krzysztofM

I am trying to:
Get back my site to work. It was all good and without any changes its suddenly down.
Your plugin is turned off, there is no menu, character encoding seems to be broken.
Changing languages should be working etc.

Link to a page where the issue can be seen: hidden link

I expected to see:
Fixed site.
E.g. "zostaÅ‚a zaÅ‚ożona" should be "została założona"

(I was not touching anything on this web last 2 years Just updating plugins if needed. There is nothing complicated.)

Here is my debug:
============================
==================================================
WPML Multilingual CMS 3.3-RC1 => Installed/Active
WPML CMS Nav Wersja n/d => Not installed/Not Active
WPML String Translation Wersja n/d => Not installed/Not Active
WPML Sticky Links Wersja n/d => Not installed/Not Active
WPML Translation Management 2.1-RC1 => Installed/Not Active
WPML Media Wersja n/d => Not installed/Not Active
WooCommerce Multilingual Wersja n/d => Not installed/Not Active
Gravity Forms Multilingual Wersja n/d => Not installed/Not Active
--------------------------------------------------
icl_translations count: 189
setup_complete: false
setup_complete missing: true
default_language: ""
default_language_missing: true

active_languages:
Array
(
[0] => stdClass Object
(
[id] => 1
[code] => en
[english_name] => English
[major] => 1
[active] => 1
[default_locale] => en_US
[tag] => en-US
[encode_url] => 0
)

[1] => stdClass Object
(
[id] => 3
[code] => de
[english_name] => German
[major] => 1
[active] => 1
[default_locale] => de_DE
[tag] => de-DE
[encode_url] => 0
)

[2] => stdClass Object
(
[id] => 42
[code] => pl
[english_name] => Polish
[major] => 0
[active] => 1
[default_locale] => pl_PL
[tag] => pl-PL
[encode_url] => 0
)

)

icl_sitepress_settings (serialized):
a:50:{s:19:"hide_upgrade_notice";s:3:"3.3";s:25:"icl_capabilities_verified";b:1;s:21:"interview_translators";i:1;s:34:"existing_content_language_verified";i:0;s:25:"language_negotiation_type";i:3;s:23:"theme_localization_type";i:2;s:14:"icl_lso_header";i:0;s:18:"icl_lso_link_empty";i:0;s:13:"icl_lso_flags";i:0;s:19:"icl_lso_native_lang";i:1;s:20:"icl_lso_display_lang";i:1;s:18:"sync_page_ordering";i:1;s:16:"sync_page_parent";i:1;s:18:"sync_page_template";i:1;s:16:"sync_ping_status";i:1;s:19:"sync_comment_status";i:1;s:16:"sync_sticky_flag";i:1;s:17:"sync_private_flag";i:1;s:16:"sync_post_format";i:1;s:11:"sync_delete";i:0;s:15:"sync_delete_tax";i:0;s:20:"sync_post_taxonomies";i:1;s:14:"sync_post_date";i:0;s:21:"sync_taxonomy_parents";i:0;s:25:"translation_pickup_method";i:0;s:15:"notify_complete";i:1;s:26:"translated_document_status";i:1;s:17:"remote_management";i:0;s:15:"auto_adjust_ids";i:1;s:11:"alert_delay";i:0;s:12:"promote_wpml";i:0;s:23:"troubleshooting_options";a:1:{s:18:"http_communication";i:1;}s:18:"automatic_redirect";i:0;s:17:"remember_language";i:24;s:17:"icl_lang_sel_type";s:8:"dropdown";s:18:"icl_lang_sel_stype";s:7:"classic";s:24:"icl_lang_sel_orientation";s:8:"vertical";s:28:"icl_lang_sel_copy_parameters";s:0:"";s:21:"icl_widget_title_show";i:1;s:28:"translated_document_page_url";s:13:"auto-generate";s:28:"sync_comments_on_duplicates ";i:0;s:3:"seo";a:2:{s:10:"head_langs";i:1;s:27:"canonicalization_duplicates";i:1;}s:22:"posts_slug_translation";a:1:{s:2:"on";i:0;}s:15:"languages_order";s:0:"";s:4:"urls";a:5:{s:30:"directory_for_default_language";i:0;s:12:"show_on_root";s:0:"";s:19:"root_html_file_path";s:0:"";s:9:"root_page";i:0;s:23:"hide_language_switchers";i:1;}s:12:"xdomain_data";i:1;s:16:"active_languages";a:3:{i:0;s:2:"en";i:1;s:2:"de";i:2;s:2:"pl";}s:22:"admin_default_language";s:9:"_default_";s:22:"taxonomy_names_checked";b:1;s:18:"ajx_health_checked";b:1;}

icl_sitepress_settings (unserialized):
Array
(
[hide_upgrade_notice] => 3.3
[icl_capabilities_verified] => 1
[interview_translators] => 1
[existing_content_language_verified] => 0
[language_negotiation_type] => 3
[theme_localization_type] => 2
[icl_lso_header] => 0
[icl_lso_link_empty] => 0
[icl_lso_flags] => 0
[icl_lso_native_lang] => 1
[icl_lso_display_lang] => 1
[sync_page_ordering] => 1
[sync_page_parent] => 1
[sync_page_template] => 1
[sync_ping_status] => 1
[sync_comment_status] => 1
[sync_sticky_flag] => 1
[sync_private_flag] => 1
[sync_post_format] => 1
[sync_delete] => 0
[sync_delete_tax] => 0
[sync_post_taxonomies] => 1
[sync_post_date] => 0
[sync_taxonomy_parents] => 0
[translation_pickup_method] => 0
[notify_complete] => 1
[translated_document_status] => 1
[remote_management] => 0
[auto_adjust_ids] => 1
[alert_delay] => 0
[promote_wpml] => 0
[troubleshooting_options] => Array
(
[http_communication] => 1
)

[automatic_redirect] => 0
[remember_language] => 24
[icl_lang_sel_type] => dropdown
[icl_lang_sel_stype] => classic
[icl_lang_sel_orientation] => vertical
[icl_lang_sel_copy_parameters] =>
[icl_widget_title_show] => 1
[translated_document_page_url] => auto-generate
[sync_comments_on_duplicates ] => 0
[seo] => Array
(
[head_langs] => 1
[canonicalization_duplicates] => 1
)

[posts_slug_translation] => Array
(
[on] => 0
)

[languages_order] =>
[urls] => Array
(
[directory_for_default_language] => 0
[show_on_root] =>
[root_html_file_path] =>
[root_page] => 0
[hide_language_switchers] => 1
)

[xdomain_data] => 1
[active_languages] => Array
(
[0] => en
[1] => de
[2] => pl
)

[admin_default_language] => _default_
[taxonomy_names_checked] => 1
[ajx_health_checked] => 1
)

==================================================
===========================-

December 5, 2018 at 2:09 am #2968397

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

it looks like WPML has been deactivated on your site

i will need to run a script to remove the error you are receiving.

which version of WPML do you currently have installed and which one was installed before ?

additionally i will need to gain administrators access and FTP access , at the moment i am not able to view the plugins,etc.

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

December 5, 2018 at 10:50 am
December 5, 2018 at 6:17 pm #2971269

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

thank you , the credentials work as expected but i am not an administrator role therefore i do not have access to activate/deactivate the WPML plugin

i did run a script through the FTP to fix this issue and now you should be able to see the option to run the configuration for WPML

once you do you should be able to see your translations as expected

let me know your results

December 5, 2018 at 6:23 pm #2971271

krzysztofM

Thanks, I've changed your account to administrator, sorry my bad.

I've configure WPML, but still it's not looking ok. Not sure if I need to change something in configuration to fix that.

December 5, 2018 at 6:40 pm #2971339

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you !

i have taken a look and i can see that WPML it self is up and running as expected with the languages showing and translations connected

the encoding issue i believe is a seperate issue from the prior error.

the warning you were getting before has been a known issue that was resolved in previous versions of WPML and wouldnt cause an encoding issue by it self

an encoding issue can happen after a database upgrade

review the following https://wordpress.stackexchange.com/questions/156626/strange-characters-despite-everything-being-utf-8

i deactivated WPML and then i can still see the issue with the encoding even with WPML deactivated

If possible i also recommend updating your WPML to version 4.1.1 as you are using an older version

=> https://wpml.org/account/downloads

The topic ‘[Closed] Encoding is broken, I got message that WPML settings maybe broken.’ is closed to new replies.