This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bobby 5 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
April 30, 2019 at 11:20 am #3710613

marekK-14

Tell us what you are trying to do?
I added new products. I do not want to translate them - just to have duplicates with canonical link in polish (main) language. I know that if I do not translate a product - WPML "duplicates" it adding only /fr/ or /en/ letters to the url and canonical url is set to main language.
It works but only on english but on french there is endless loop.

Example:
Polish (main language)
hidden link

English (that works ok)
hidden link
(I hid with css the description in other than polish langages)

French (that causes endless loop)
hidden link

I have following settings on product option: use the translation, if available, or return to the default language.

Thanks in advance for help.
Regards,
Dominik

April 30, 2019 at 6:43 pm #3714307

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Dominik,

do you currently use any plugins that might have caused some 301 redirects ?

I did a redirect inspection on your URL and the following are my results

hidden link

HTTP/1.1 301 Moved Permanently
X-Powered-By: PHP/7.2.15
Set-Cookie: apbct_timestamp=1556649580; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: apbct_site_landing_ts=1556649580; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: apbct_page_hits=1; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: apbct_cookies_test=%257B%2522cookies_names%2522%253A%255B%2522apbct_timestamp%2522%252C%2522apbct_site_landing_ts%2522%252C%2522apbct_page_hits%2522%255D%252C%2522check_value%2522%253A%2522463e07e847da48956306861afb03cf23%2522%257D; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: ct_sfw_pass_key=4ffdce5b1b6c0bad2b9a33fb04b5ee3e; expires=Thu, 30-May-2019 18:39:40 GMT; Max-Age=2592000; path=/; domain=artkomiks.pl; HttpOnly
Expires: Wed, 11 Jan 1984 05:00:00 GMT
Cache-Control: no-cache, must-revalidate, max-age=0
Location: /fr/produit/pinochio-the-emperor-of-the-night-20502-seq8-komplet/
X-Redirect-Agent: redirection
Set-Cookie: _lscache_vary=7c0380f629e02acd8c88d79cf10a2bb2; expires=Thu, 02-May-2019 18:39:41 GMT; Max-Age=172800; path=/; secure; HttpOnly
X-LiteSpeed-Cache-Control: no-cache
Content-Type: text/html; charset=UTF-8
Content-Length: 0
Date: Tue, 30 Apr 2019 18:39:41 GMT
Server: LiteSpeed
Alt-Svc: quic=":443"; ma=2592000; v="35,39,43,44"
Connection: Keep-Alive

hidden link

HTTP/1.1 301 Moved Permanently
X-Powered-By: PHP/7.2.15
Set-Cookie: apbct_timestamp=1556649583; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: apbct_site_landing_ts=1556649583; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: apbct_page_hits=1; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: apbct_cookies_test=%257B%2522cookies_names%2522%253A%255B%2522apbct_timestamp%2522%252C%2522apbct_site_landing_ts%2522%252C%2522apbct_page_hits%2522%255D%252C%2522check_value%2522%253A%252283cb6ef168e5166ebe090a9a45ab45a2%2522%257D; path=/; domain=artkomiks.pl; HttpOnly
Set-Cookie: ct_sfw_pass_key=4ffdce5b1b6c0bad2b9a33fb04b5ee3e; expires=Thu, 30-May-2019 18:39:43 GMT; Max-Age=2592000; path=/; domain=artkomiks.pl; HttpOnly
Expires: Wed, 11 Jan 1984 05:00:00 GMT
Cache-Control: no-cache, must-revalidate, max-age=0
Location: /fr/produit/pinochio-the-emperor-of-the-night-20502-seq8-komplet//fr/produit/pinochio-the-emperor-of-the-night-20502-seq8-komplet/
X-Redirect-Agent: redirection
Set-Cookie: _lscache_vary=7c0380f629e02acd8c88d79cf10a2bb2; expires=Thu, 02-May-2019 18:39:43 GMT; Max-Age=172800; path=/; secure; HttpOnly
X-LiteSpeed-Cache-Control: no-cache
Content-Type: text/html; charset=UTF-8
Content-Length: 0
Date: Tue, 30 Apr 2019 18:39:43 GMT
Server: LiteSpeed
Alt-Svc: quic=":443"; ma=2592000; v="35,39,43,44"
Connection: Keep-Alive

hidden link

May 1, 2019 at 10:45 am #3717679

marekK-14

Yes, there is a redirect tool. And I remove the wrong redirect that caused the redirection.
Now the situation changed. The english version is still ok.
But the french version gives 404.

Example:
Polish (main language)
hidden link

English (that works ok)
hidden link
(I hid with css the description in other than polish langages)

French (NOW GIVES 404)
hidden link

Regards,
Dominik

May 1, 2019 at 5:00 pm #3718957

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please verify that you do not have any pages within the trash as this can cause such behavior. If you do please empty the trash completely and let me know your results

if that does not resolve the issue i would like to take a closer look if possible

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

May 2, 2019 at 7:34 pm #3728805

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i can verify that this is being caused by your plugin LiteSpeed Cache, please review your settings within the plugin especially the ones for the Woocommerce.

to test you can deactivate it and then access the product, no more 404.

May 7, 2019 at 11:18 am #3756967

marekK-14

Hello,
Thank you very much. This is strange. Now I turned the litespeed cache plugin off and on again. And everything works fine. I cleaned the whole cache before but it did not help.
So by now the problem is gone.

By the way - one more question in this situation. When I am on the secend and third language page (english and french) - is it possible to have attributes translated? So if the slug is changing, attributes could also change...
Now on every page there are main langage (polish) strings there:
hidden link

e.g.:
Technique: ołówek, tusz

For instance the attribute "ołówek" have its english version:
hidden link

but the links leads to polish attributes.

Can anything be done about it?

Thank you.
Dominik

May 7, 2019 at 5:25 pm #3761003

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

the translation is not showing for the attributes because you are using "display as translated" to display the product in the secondary languages.

once the product is fully translated to the secondary language then the translation of the attributes takes effect but at the meantime that is why it is not showing as translated