Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by Bruno Kos 1 month, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
October 22, 2019 at 8:23 am

maxL-15

Refering to https://wpml.org/forums/topic/endpoint-translations-undone/

I need a fix right now because the e-mail campaign will be sent today.

October 22, 2019 at 10:28 am
October 22, 2019 at 10:34 am #4801369

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

This has been escalated to our Compatibility team and may take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

October 23, 2019 at 12:26 pm #4811403

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Can you try this?

1- Go to WooCommerce -> Settings -> Advanced.
2- Change the text of all endpoints to English.
3- Go to String Translation and switch to WP Endpoints text domain.
4- Delete all strings there.
5- After the page reloads, find the endpoints registered in English and translate.

Is it working?

Regards,
Bruno Kos

October 28, 2019 at 4:14 pm #4841583

maxL-15

Can you try it first in the sandbox environment? Or did you already?

October 29, 2019 at 8:07 am #4844429

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

We tried this on the sandbox installation and worked:
hidden link

You can see how this is set here - especially within string translation.
hidden link

Regards,
Bruno Kos

October 29, 2019 at 9:23 am #4845235

maxL-15

Unfortunately not working!!

Same error, same screen.....

October 29, 2019 at 9:25 am #4845309

maxL-15

For .nl its working again. I feel like there is something wrong with WPML and the other domains. That we need to look into that direction?

October 29, 2019 at 9:36 am #4845423

maxL-15

I just saw this in Woocommerce Multilingual Store URLS. Maybe we need to do something with that too? It is Dutch and English mixed and doubled.

October 29, 2019 at 10:57 am #4846371

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

From what I see, the same thing is here as well:
hidden link

But in this website it is working perfectly.

Can I ask you the following then? In order to debug this issue , I will install Duplicator plugin, will create packages and will try this on my localhost and possibly escalate further to 2nd tier.

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

This is a very tricky issue to get resolved, but the other day one of the other clients reported it as well and when I tested this on a on my localhost, it worked, so it was a compatibility issue with some plugin, not sure which one was it because there were over 60 plugins installed.

I assume that you haven't changed the logins since this ticket has started?

Regards,
Bruno Kos

October 29, 2019 at 10:59 am #4846421

maxL-15

That's fine. Just do your thing. Login is still the same. Let me know!

October 30, 2019 at 8:04 am #4853183

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

This has been escalated to our 2nd Tier team and may take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

October 31, 2019 at 7:29 am #4860805

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

We tried this and it worked:

- removing all entries in WPML > ST for the domain WooCommerce Endpoints
- setting default product permalink from Shop base with category to Default
- Resaving permalinks
- Then returning it back to Shop base with category - e.g. /shop/%product_cat%/
- Resaving permalinks

I removed endpoints on your site, but I'm unable to perform any of the other steps. When I go to hidden link, if I try to change Product permalinks, it never saves, always reverts to the custom. Are you having some plugins or htaccess setting which is preventing this to be saved?

Regards,
Bruno Kos

October 31, 2019 at 7:47 am #4860925

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Also note that when testing, the only way when we were able to save permalinks was in a very minimal setup with a default theme, so unless you know what prevents them, I suggest you go this route.

Regards,
Bruno Kos

October 31, 2019 at 7:53 am #4860943

maxL-15

I think you were seeing a cached page. I see that you changed the permalink to /product.

We need to anticipate fast because the product pages don't look good now.

You can try disabling Yoast SEO and WP rocket. Yoast SEO puts Redirects in HTACCESS and WP rocket is the caching plugin.

I can also perform it for you.

What exactly do you need me to do?

Please let me know asap.