Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Maciej 4 years, 6 months ago.

Assigned support staff: Maciej.

Author Posts
June 26, 2015 at 7:16 pm #647519

occaalessandra

I am trying to: translate website content

URL of (my) website where problem appears: hidden link

I expected to see: english pages

Instead, I got: can't find page

June 29, 2015 at 7:30 am #648105

Maciej

Hello,

Thank you for reporting your issue.

To better understand how to move forward with a solution, could you please provide information about your environment by following these steps: http://wpml.org/faq/provide-debug-information-faster-support/

Regards,
Maciej

June 29, 2015 at 9:09 am #648202

occaalessandra

I have deactivated the english language at the moment cause it is not working properly and I need the website working.
I hope you'll be able to understand the problem anyway.

The translated menu link every page to the wrong url

I give you an example:
hidden link
has a translated page named:
hidden link

the english menu link the translation to
hidden link
and then appear a can't find page message

what can I do?
Thank you

June 30, 2015 at 1:26 am #648921

Maciej

Thank you for your reply.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

I would also recommend to backup your database and website first before we proceed. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

July 10, 2015 at 3:55 am #656533

Maciej

Hello,

Thank you for the login details.
You English language was set to hidden in "Nascondi lingue".
I have also change your "Formato degli URL per le lingue" to "Directory con lingue diverse".
All the English pages from your menu work now without any problems.

Please let me know if this solves your issue.

Regards,
Maciej

The topic ‘[Closed] eng menu does not link to ?lang=en version so it appear can't find page’ is closed to new replies.