This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
June 13, 2019 at 5:42 pm

jerryd-4

I am trying to:

We have a webshop with the languages ENG & NL. ENG is the first language, NL the second.
When we add a new product of want to adjust a product, we see everywhere yellow locks?

We think that there is somewhere an option to set the Shop to ENG as a mother tongue. It seems like that the mother language is Dutch?
hidden link

I expected to see:
That we can the ENG products at the normal way that we dont see yellow locks.

June 13, 2019 at 7:03 pm #4016467

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It seems your products were originally created in dutch and then the english ones were added as the translations of dutch products, in order to change it, you can try the following:

1 - Temporary disable the WooCommerce Multilingual plugin.

2 - Click to edit each english product from your WordPress Dashboard > Products > All Products and detach its translations references in the language box at the page editing screen, instead of making it a translation of a dutch product, make it as '--None--' from the 'This is a translation of ' settings, update the product and you should be done. See attached image.

3 - Now repeat the steps above on each dutch product from your WordPress Dashboard > Products > All Products and make them a translation of the respectives english products in the language box at the page editing screen, from the 'This is a translation of ' settings, update the product and you should be done.

4 - Activate the WooCommerce Multilingual plugin and you should be done.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Hope it helps, have a nice day.

June 13, 2019 at 7:06 pm #4016495

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Ticket status update.

June 13, 2019 at 8:40 pm #4016877

jerryd-4

Hi Marcos,

Is there a way to select all the products and than select it to none?
Maybe you can do it for us? Because our customer is complaining about this...

Thank you in advance!

With best regards,

Jerry

June 14, 2019 at 7:27 pm #4023879

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Unfortunately there's no such feature of bulk selection and to switch default/secondary language for products. Also, we are not able to make it for you as we have a queue of support and doing so would require some extra time of effort from our side which could impact in the time we need to dedicate to our queue of support. I see you have currently 30 products published which doesn't seem to be a big deal to make it manually. Sorry for not being able to help this way, thank you for your understanding and collaboration, have a nice day.

June 17, 2019 at 8:23 am #4033123

jerryd-4

Hi Marcos,

I followed your steps, but at the Dutch product overview it is going wrong;

1. At the ENG product overview, I change the it to none.
2. I went to te same product at the Dutch, but I see anywhere the option: from the 'This is a translation of ' settings, update the product and you should be done.

See images. What did I do wrong?

June 17, 2019 at 6:03 pm #4037713

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Sorry, the correct workflow should be:

1 - Click to edit your english product and set it as 'None' for its 'This is a translation of ' and update the product post.

2 - Now in the same english product, choose the option 'Connect with translations' and choose the respective dutch product from the dialog box and click the 'assign' button. See attached image.

Note: I have already performed the steps above on your 'Chanel Medium Classic flap bag' product.

Please, let me know if it helps this time. Have a nice day.

June 17, 2019 at 6:05 pm #4037737

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Ticket status update.