This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by charlotteE-2 4 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
September 21, 2019 at 3:27 pm #4616409

charlotteE-2

I am trying to: Write a blog and have a blog archive in both languages (and blog psots as well)

Link to a page where the issue can be seen: hidden link

I expected to see: Norwegian in the Norwegian archive

Instead, I got: my latest post appears in English in the Norwegian archive. However, when clicked, it links to the Norwegian version

September 23, 2019 at 8:28 am #4621569

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Is this happening with hidden link only? I do see that it is there, it seems to be the only Norwegian post, however when opening it ( when on a hidden link), I see that it redirects to 404.

Can you try to following:
WPML -> Settings -> Language filtering for AJAX operations -> Enable this
WPML -> Settings -> Post Types Translation -> Posts (post) -> Translatable - only show translated items

Alternatively, can you delete that post and try re-creating it anew ( or perhaps translating it), see what happens then? Maybe it got the wrong language assigned for some reason, but since it does not exist in other language, then it points to wrong URL.

Regards,
Bruno Kos

September 23, 2019 at 2:28 pm #4624975

charlotteE-2

My issue is resolved now. Thank you!