This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by ezioP 1 week ago.

Assigned support staff: Riffaz.

Author Posts
October 4, 2019 at 11:17 am #4695097

ezioP

I am trying to: solve the problem with the wrong float on the English flag on the main menu

Link to a page where the issue can be seen: hidden link

I expected to see: the English flag to float on the right like the attached: good-flag float right.

Instead, I got: the English flag floated on the left

October 4, 2019 at 4:05 pm #4697243

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @eziop, welcome to the WPML support Forum!

Please add the following code to Appearance > Customize > Additional CSS:

.c-header-1-nav>ul>li.sub ul li a { min-width: 68px !important; }

Please let me know if it worked for you.

All the best,
Diego

October 5, 2019 at 9:22 am #4700175

ezioP

Dear Diego,
thank you for this solution which is not bad... I did try but it is reducing also the width of other submenu voices.

Would be possible for WPML to show the same position and width for both flag: Italian and English? Like the attached, the Italian flag is perfect... hope also the English will be the same.

Thank you in advance.
Agos

October 6, 2019 at 6:55 am #4701767

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Diego is off and I will be helping you on this.

Add this code

@media (min-width: 992px){
.c-header-1-nav>ul>li.sub.last-menu-item>ul {
    right: unset;
}
}
.c-header-1-nav>ul>li.sub ul li a {
    padding-left: 19px;
}

Then your switcher should look like this: hidden link

Let me know if you need anything else regarding this.

Regards,
Riffaz.

October 7, 2019 at 8:42 am #4705621

ezioP

My issue is resolved now. Thank you!