This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Lauren 1 month, 1 week ago.

Assigned support staff: Lauren.

Author Posts
September 11, 2019 at 7:24 pm #4556149

cristinag-22

I just changed default language to spanish (before it was english).
Now everything works perfect in spanish and french. But in english (old default language) home dissapeared, and language selector doesnt find any home in english (though it exists). It was old default home, may it affect?
hidden link

September 11, 2019 at 8:15 pm #4556369

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please send me a copy of your site using All In One Migration. This way, I can set it up locally and test further. I have marked the next reply as private so that you can safely send me the download link.

September 12, 2019 at 1:42 pm #4561367

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the export file. I was able to set up a copy of your site and without making any changes, the English page loads without any problem. I added a footer widget and can switch back and forth between all languages.

The only difference between your live site and my test site is the hosting platform. Perhaps you can ask your hosting provider to see if there are any errors showing in the error log?

I also reviewed the ticket that you mentioned but that ticket is not related. That ticket is using different domains per language and the problem was in the server settings.

One other thing you might try is installing this plugin to deactivate the auto guess component of WordPress: https://wordpress.org/plugins/disable-url-autocorrect-guessing/

September 13, 2019 at 7:00 am #4565929

cristinag-22

Hello!
I´ve been working on these. All works fine if I´m logged on wordpress. But if I´m not logged or use incognito window, home doesn´t appear in any of the secondary languages. Can you guess what´s the problem?

September 13, 2019 at 7:11 am #4565971

cristinag-22

Hello again!
More advances. I installed that plugin, so I see now the problem is in the mohe header logo, which redirects to cristinagilevents.com/en/en instead of cristinagilevents.com/en. That two EN/EN are the problem. Same if I write cristinagilevents.com/en on navigation bar, it redirects to cristinagilevents.com/en/en and shows 404. But if I clic menu home section, it goes to cristinagilevents.com/en/ and works fine. I think its better if I give you my wp user and admin so you can enter to my actual version. Please tell me!

September 13, 2019 at 7:19 am #4565991

cristinag-22

exactly same as here https://wpml.org/forums/topic/logo-and-home-links-link-to-en-en-and-da-da-double-language-path/
But also I do not want to use trailing slash on my URL, are there other alternatives?

September 13, 2019 at 1:43 pm #4568997

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Were you able to ask the hosting provider for the server logs? Because on the local copy of your site, the page redirects correctly from the footer language switcher whether I am logged in or not. You mentioned linking from the logo - please try adding a footer language switcher. You can do this in WPML -> Languages. Do you see the same behavior from the footer language switcher as you do from the logo?

If so, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, is the issue resolved?

September 13, 2019 at 4:35 pm #4570111

cristinag-22

how shall I Update all WPML plugins?

September 13, 2019 at 4:49 pm #4570183

cristinag-22

1) SAME PROBLEM WITH FOOTER LANGUAGE SWITCHER

2) ** IMPORTANT ** Please backup a working copy of site files and database before continuing. DID IT!

3) Update all WPML plugins & WordPress core. DON´T KNOW HOW CAN I DO IT

4) Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, is the issue resolved? DON'T WANT TO DO THAT!
5) IM SENDING YOU A COPY OF HOW WEBSITE IS ACTUALLY TO YOUR MAIL

September 13, 2019 at 5:30 pm #4570253

cristinag-22

If you write hidden link on navigation bar, all works well. If you write hidden link (no trailing slashes at the end) it redirects to hidden link.
Same happens clicking language selector and logo on header which redirects to home.
So it must be something related to that....

September 13, 2019 at 5:36 pm #4570265

cristinag-22

So many people telling the same thing....https://wpml.org/forums/topic/auto-redirect-when-enter-url-without-trailing-slash/

September 13, 2019 at 7:38 pm #4570531

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have sent some instructions for migrating the site in my previous reply. Please let me know when the migration is completed, and we can continue troubleshooting there.

The topic ‘[Closed] english home is not appearing’ is closed to new replies.