Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 5 years, 4 months ago.

Assigned support staff: Bobby.

Author Posts
February 28, 2016 at 7:57 pm #825363

attiahA

Hello
my website hidden link
main language is English
i have select Arabic and French language
in main page only English language icon appear and other language missing
in hidden link , hidden link all icons appear without any problem

please see
hidden link
hidden link
hidden link

February 29, 2016 at 12:53 pm #825956

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for contacting the WPML support!

Please test this:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Also => Please verify that you have translations in both secondary languages

if not then go to WPML=>Languages , and enable " Link to home of language for missing translations" and "All posts (display translation if it exists or posts in default language otherwise)."

Let me know your results please.

Kind Regards,
Bobby

March 1, 2016 at 3:28 am #826594

attiahA

This is the replay from the Theme Suuport

The language selector is not provided by WPLMS so the issue does not originate from Wplms.

Several users have been able to add this in exact same position as in your site.

March 1, 2016 at 3:30 am #826595

attiahA

Please check with me now
i have apply this step

Also => Please verify that you have translations in both secondary languages

if not then go to WPML=>Languages , and enable " Link to home of language for missing translations" and "All posts (display translation if it exists or posts in default language otherwise)."

March 1, 2016 at 9:52 am #826827

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

When i visit your site i can see all the language options right now

Thank you,
Bobby