If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Alex 1 month, 1 week ago.

Assigned support staff: Bobby.

Author Posts
October 10, 2019 at 8:54 pm

Alex

I am trying to:

Have the english site working

Link to a page where the issue can be seen:

hidden link

I expected to see:

English page, instead got redirected to the original page (same for all pages)

What I tried:

Changing the "Different languages in directories" to something else fixes the issue but I need /en/

October 11, 2019 at 4:28 am #4735527

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

The password seems to not be working for wp-admin, if possible please verify it.

When you switch to "language name added as parameter" is it working as expected?

Please click on the warning "Details" and share the message with your hosting provider as this is related to the hosting environment.

Let me know their feedback.

October 11, 2019 at 12:03 pm #4737935

Alex

Yes if I change it to "language name added as parameter" it works as expected but this is not the option that I want.

For the "warning/modal" I gave you the info to login next to the WP-Admin URL -- For the WP-Admin password how can I send it to you? 🙂

October 11, 2019 at 6:27 pm #4740743

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

WPML is letting you know that your installation will not be able to use the URL Format for "languages per directories ".

1. Is your WP installed in a root directory?
2. Are you using the default Permalink structure? If yes please switch to the "post-name" structure.
3. Verify that URL rewriting is not enabled in your web server
4. Verify that the webserver can write to the .htaccess file

The wp-admin password is not working for me to access the backend.

October 11, 2019 at 6:30 pm
October 12, 2019 at 12:12 am #4741355

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

The issue is being caused by the "Redirection" plugin.

1. Go to Plugins->Deactivate Redirection plugin
2. Open the home page and test in an incognito browser window

Screeencast:
hidden link

October 12, 2019 at 12:22 am #4741357

Alex

Ah crap, is there anything to do except disable the plugin? We have another site with this plugin + WPML and it works fine. Otherwise, thanks so much Bobby!

October 12, 2019 at 1:20 am #4741395

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I went into Tools->Redirection->Redirects and scanned for /en/.

Afterwards, I removed any redirects for /en/ and it seems that it might have done the trick, please test on an incognito window.

October 12, 2019 at 3:26 pm #4743099

Alex

My issue is resolved now. Thank you!