This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bruno 5 months ago.

Assigned support staff: Bruno.

Author Posts
May 14, 2019 at 10:52 pm #3810983

kristinaC-2

The English shop page is not displaying the English products that have been created. If you swap to the French version of the shop the french products show up correctly.

Link to a page where the issue can be seen:
hidden link
hidden link

Here is an english product that should be displaying:
hidden link

Periodically the shop will be able to load up with the english products displaying correctly but they will disapear after a refresh.

May 14, 2019 at 11:39 pm #3811031

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. This looks like this page is not connected to WooCommerce.

In WooCommerce > Settings > Products, would you please confirm that the "Shop" page is selected? I'll attach an image for you to see.

Thank you.

May 15, 2019 at 3:43 pm #3818485

kristinaC-2

Yep the shop page is set within Woocommerce settings. If you inspect the page also you will see that the Woocomerce products wrapper is there it just has no products within it.

May 15, 2019 at 7:22 pm #3819859

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for checking this out. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 16, 2019 at 9:27 pm #3829463

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I tried to create a copy of your site using Duplicator, but this did not work. It looks like the PHP ZipArchive extension is not enabled on your host.

Also, by analyzing your site a little more, I'm not sure if this is related to WPML. Since this works correctly in the secondary language, WPML by default should not influence the primary language.

Have you tried to disable all non-WPML plugins (keeping WooCommerce and WooCommerce Multilingual) to see if the problem persists?

May 16, 2019 at 10:43 pm #3829675

kristinaC-2

Ok so I have disabled all plugins other than WPML and Woocommerce and swapped to the default 2019 theme and am still seeing the same issue. No products displaying on the english store with the french working..

hidden link
hidden link

May 16, 2019 at 10:57 pm #3829813

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Now it looks like the products are being displayed correctly in both languages. I just saved the permalinks again (Settings> Permalinks).

Please, could you check?

May 17, 2019 at 4:14 pm #3835963

kristinaC-2

So it looks like the issue is partially fixed when permalinks are re-written. It looks like the bug is related to the Paid Member Subscription plugin from Cozmo Labs. (hidden link). With that plugin activated anytime you swap between the eng/fr versions of the shop the english products disappear. re-saving the permalinks brings them back but only until you swap the shop language again.

I have submitted a ticket with the plugin author also so hopefully they have an idea what would cause this..

May 17, 2019 at 6:40 pm #3836547

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

This may be probably happening if the "Paid Member Subscription" plugin is regenerating the permalinks with each access.

Please let me know what the "Paid Member Subscription" plugin author says so I can check with our team too.

Thank you.

The topic ‘[Closed] English shop page is not displaying English products’ is closed to new replies.