This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by hooiC 4 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
March 29, 2019 at 7:27 pm #3494323

hooiC

I am trying to: we migrated the database from development to production. We noticed the English(default language) content is in the German(secondary language) site. see image attached. It should be in German. on our development site -everything is fine.
i went into troubleshooting and action the followings and did not fix the issue. after this I pretend to update Home page in English(default) and update the German Home page. still did not solve the issue
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

March 30, 2019 at 10:13 am #3497923

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

it seems that particular section is pulling information from the (German) blog, and it's pulling the original "excerpt". Can you tell me what are you using in that section? is it ACF or any other tool?

I mean, how is that excerpt extracted?

let me know so i can better understand what's going on.

Best wishes,

Alejandro.

April 1, 2019 at 6:11 am #3504043

hooiC

Hi Alejandro, thank you for getting back to me so quickly. I don't know how this is built. but this is in Avada Fusion . if you go to hidden link and do page source view and search for : Your fertile period lasts about..(this is in english) you will find this script below. if you click on "read more" it takes you the page in hidden link.

<img class="lazy lazy-hidden" src="//mylotus.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="/wp-content/uploads/2018/09/trying.png" width="100%" alt="Planning your pregnancy" typeof="Image" /><noscript><img src="/wp-content/uploads/2018/09/trying.png" width="100%" alt="Planning your pregnancy" typeof="Image" /></noscript>
</div>
</div>
</div>
<div class="peosays">
<div class="col-md-6">
<div class="box">
<h4>Knowing your most fertile days</h4>
Your fertile period lasts about 6 days and ends on the day of ovulation.<br />
<br />
The day of your LH surge and the day after are your two most fertile days in your cycle <br />
<br />
If you have unprotected sex within your most fertile days you maximise your chances to conceive. <br />
<br />
<a href="/planning-your-pregnancy/#amiovulating" target="_blank">READ MORE</a>
</div>
</div>
<div class="col-md-6">
<div class="box">
<img class="lazy lazy-hidden" src="//mylotus.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="/wp-content/uploads/2018/09/mlotus-lh-curve-chart-english.png" width="100%" alt="Knowing your most fertile days" typeof="Image" /><noscript><img src="/wp-content/uploads/2018/09/mlotus-lh-curve-chart-english.png" width="100%" alt="Knowing your most fertile days" typeof="Image" /></noscript>
</div>
</div>
</div>

April 1, 2019 at 6:29 am #3504229

hooiC

Hi Alejandro
I went into the traslated HOme page in German, and found the fusion content in English. so I copied the script and content from the dev site and paste into that section in the TRanslation mode. the above issue now resolved. But to avoid this issue, is there a way of making an copy of live site to dev site(or vice versa) without this issue happening? in fact we experienced during migration from dev to production ( or production to development), we lose the avada theme formatting and default translation content(english) in the secondary languages only in those where its built in avada fusion container. do you think we should turn off any cache plugin(like varnish or t3 total) before migration?

April 1, 2019 at 6:41 am #3504357

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,

You should definitely turn off and clear all types of caching when you migrate from development to production, and also you should make sure your migration plugins (if you use some) are excluding the cache folders.

I'm glad the problem is solved now, don't hesitate to let us know if you encounter any other WPML-related issue you need our help with, we'll gladly help you.

April 2, 2019 at 8:19 am #3514671

hooiC

Hi Alejandro,
we did not "migrate" the site, we simply changed the domain that the site was using ie changing URL from dev site to live site.We replaced the urls in the database dump from webdev.mylotus.com to mylotus.com etc. ( for all the languages subdomains). W3TC was switched off. The only other cache would have been the Avada styles and javascript which was not turned off before migrating. Not sure how this would affect page content. do we need this off , too?
Perhaps there is a WPML cache that we are not aware of that requires clearing.
is this a good approach to clone a dev to live site ( or from live to dev site) ie just changing the url in the database dump?

April 2, 2019 at 9:19 am #3515273

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm not sure about the avada styles but if you can clear that cache you'll definitely not have negative effects.

About WPML cache, we do have one, you can clear it by going to WPML > Support > Troubleshooting > Clear WPML Cache.

You can try that.

April 2, 2019 at 11:31 am #3516517

hooiC

My issue is resolved now. Thank you! we will bear your recommendation in mind when we make a copy of the live site to dev site or vice versa.