Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by jonathanF-3 3 years, 3 months ago.

Assigned support staff: Andrey.

Author Posts
March 28, 2018 at 4:58 pm

jonathanF-3

We are using the Envira Gallery with the image Tags extension on a bilingual website.

The tags were translated in the back-end, but the translation isn't showing on the front-end.

March 30, 2018 at 1:31 pm #1560925

Andrey
Supporter

Timezone: Europe/Kiev (GMT+02:00)

It sounds like a compatibility issue but looking at an example here: hidden link, I can see that the tag label "Dépoussiérage" is translated on the front-end. Did I miss something?

Also, as far as I can see you need to make "Envira Gallery" post type translatable. This can be done when you edit the gallery entry at the bottom of the page. Or from WPML >> Translation Management >> Multilingual Content Setup.

March 30, 2018 at 1:42 pm #1560930

jonathanF-3

Hi Andrey, wow I didn't change anything. Wondering if it was a caching issue (we are running on flywheel). There's still 1 thing to translate ; The word "Tout" from the tags. Is that a string ?

March 30, 2018 at 1:44 pm #1560931

jonathanF-3

Just noticed something. While I haven't change anything, the english tags are now shown on the french page.... did you change something ?

March 30, 2018 at 3:14 pm #1561007

Andrey
Supporter

Timezone: Europe/Kiev (GMT+02:00)

I haven't changed anything on your website, just observed the settings.

Where the word "Tout" can be seen. Could you show me on the screenshot?

March 30, 2018 at 3:41 pm #1561052

jonathanF-3

Please have a look at the page "Latest projects". "TOUT" is the first tag to filter the pictures. It should be "ALL" since the page is english.

April 2, 2018 at 12:55 pm #1562246

Andrey
Supporter

Timezone: Europe/Kiev (GMT+02:00)

Probably it is related to the fact that your "Envira Gallery" post type isn't set as translatable as I mentioned before.

I would suggest making it translatable. After, for the "Our cleaning projects" page, add the translated version of the shortcode [envira-gallery id="761"], and then check the results.
Don't forget set value "All" for "All Tags Label" field instead of "Tout" in the Envira Gallery.

1.png
April 3, 2018 at 8:39 pm #1564088

jonathanF-3

Did you check the setting page regarding the tags translation ? This was already done from 1 week ago.

Also, as far as I know, there is no "translated version" of the shortcode. I dont want to create 2 different gallery, I simply want to translate the tags. They are already translated, but they aren't showing on the front end. That's the problem since the begining.

Untitled-1.jpg
April 4, 2018 at 12:59 pm #1564815

Andrey
Supporter

Timezone: Europe/Kiev (GMT+02:00)

I do understand the problem. I am quite sure that the reason for the problem is that the custom post type is not set as a translatable. As far as I can see you have specified the tags inside that gallery for the default language only when you edit it, so it is expected.
Those tags translation that have been done already, you'll be able to choose on the translated version of the gallery.

I can't think of any other solution. I would suggest you test what I wrote. It can be done on the test site first if you have it.

Thank you.

April 9, 2018 at 5:24 pm #1574757

jonathanF-3

Ok I will check that and get back to you.