This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: We are using WPML Multilingual CMS together with the plugin WooCommerce Product Filter | Version 6.6.5 | By Mihajlovic Nenad | https://mihajlovicnenad.com/product-filter/.

The plugins works almost perfectly together but we are facing a problem with links. We are getting some ERR_TOO_MANY_REDIRECTS by some of the pages. We have test it with other pages on our website and when we want to filter and the filter contains only a figure the error ERR_TOO_MANY_REDIRECTS comes up.

Solution: There is an errata describing a solution for this issue: https://wpml.org/errata/numerical-category-slugs-can-possibly-lead-to-redirection-loop/

Relevant Documentation:

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Carlos Rojas 6 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
March 26, 2019 at 12:48 pm #3462437

WebDustE

Hi WPML,

We are using WPML Multilingual CMS together with the plugin WooCommerce Product Filter | Version 6.6.5 | By Mihajlovic Nenad | hidden link.

The plugins works almost perfectly together but we are facing a problem with links. We are getting some ERR_TOO_MANY_REDIRECTS by some of the pages.

We already test several thinks. For example when we us a filter on our page ALUMINUM MOTORS page (hidden link) and we choose for the filter Motor Size | 90S the page is showing perfectly and the link is also showing correctly. See on screenshot 1

If we choose on the same page (hidden link) for Motor Size | 63 than we get the following error ERR_TOO_MANY_REDIRECTS and we see a wrong link. See on screenshot 2

We have test it with other pages on our website and when we want to filter and the filter contains only a figure such as the example above the error ERR_TOO_MANY_REDIRECTS comes up.

Our first step was to deactivated some plugins and checked out when the filter was work correctly again. When we deactivated the plugins WPML Multilingual CMS the see that the filter works again. See on screenshot 3. Here you can see that we have choose for the filter Motor Size | 63 and than the page work perfectly again.

This bug is now on our developing site hidden link. Our developing site is timely accessible for every one now. Our live website is hidden link where we have deactivated the WPML plugin.

We hope that you can help us with this fact.
Kind regards and thanks for the great support
Dust

March 26, 2019 at 7:24 pm #3465883

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Dust,
Thank you for contacting WPML support.

1.- Could you tell me if the broswer redirect option is activated in WPML -> Languages?
If this option is activated I kindly ask you to deactivated it and check again.

Also, please go to WPML -> Languages -> Activate the Ajax cookie and save the changes.

Could you tell me the result of the steps above?

2.- Please contact yoru hosting providers and ask them to update the MySQL version to meet our minimum requirements: https://wpml.org/home/minimum-requirements/

Kind regards,
Carlos

March 27, 2019 at 3:45 pm #3473067

WebDustE

Hi Carlos,

Thanks for your feedback. Below you'll find mine.

1.- Could you tell me if the broswer redirect option is activated in WPML -> Languages?
If this option is activated I kindly ask you to deactivated it and check again.
- It was already deactivated.

Also, please go to WPML -> Languages -> Activate the Ajax cookie and save the changes.
- Yes i have activate the Ajax cookie

Unfortunately these option not solved the issue.

I have ask my hosting provider to check out which MySQL.

I will keep you updated about the MySQL server.

Kind regards
Dust

March 27, 2019 at 3:58 pm #3473181

WebDustE

Hi Carlos,

Just get the information from our hosting provider and the MySQL is above 5.6.

Do you have any suggestions? This bug is only showing when we filter on a figure.

Kind regards
Dust

March 27, 2019 at 5:38 pm #3474301

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dust,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

March 29, 2019 at 12:00 am #3486129

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dust,
Thank you very much for the information provided.

I suspect that the cause of this issue is the slug of the tags, could you tell me if the issue persists if you add a letter or a different slug to the tag '63'?

Regards,
Carlos

March 29, 2019 at 8:48 am #3489211

WebDustE

Hi Carlos,

Yes that's correct. If we add a letter than the filter works correct. But also check the plugin WPML Multilingual CMS. When you disable it the filter works as it should be.

Regards
Dust

March 29, 2019 at 3:08 pm #3492489

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dust,
I'm glad to hear that the issue was solved 🙂

However, I was consulting with on of our specialists and there is an errata describing a solution for this issue: https://wpml.org/errata/numerical-category-slugs-can-possibly-lead-to-redirection-loop/

Please don't hesitate to contact us if you need our help in the future with WPML.
Best regards,
Carlos

April 2, 2019 at 10:11 am #3515801

WebDustE

Hi Carlos,

Thank you very much. This was the solution: https://wpml.org/errata/numerical-category-slugs-can-possibly-lead-to-redirection-loop/

Now one question 😉 hen we update the plugin do we always have to go through this step or will this be included with the next plugin update?

Or is it possible to we add this piece of code in our child theme?

Thanks again for the solution
Kind regards
Dust

April 2, 2019 at 4:18 pm #3519077

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dust,
I'm glad to hear that the issue is solved 🙂

Today or tomorrow a new version of WPML will be released. I recommend you to wait until this new version is installed in your site and check if the issue persists. In case the issue persists, then apply the same workaround after updating the plugin.

Best regards,
Carlos

April 3, 2019 at 7:52 am #3523251

WebDustE

My issue is resolved now. Thank you very much Carlos and WPML Team!
Kind Regards
Dust

April 3, 2019 at 1:55 pm #3526827

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dust,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos