This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 19 replies, has 2 voices.

Last updated by Анна Ерохина 6 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
April 8, 2019 at 10:18 am #3556487

Анна Ерохина

Im trying to run multilingual
i tried to run health check and i dont understand actually what to do to fix this issue

umpg.com.ua

How can i give you an acces to admin area to see what kind of problem i got?

April 8, 2019 at 10:22 am #3556547

Анна Ерохина

This is the full name of theme i use

satelite-creative-ajax-portfolio-showcase-slider-theme

April 8, 2019 at 10:25 am #3556627

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry for missing this chat. Can you please reply now and we'll be able to continue this as a regular ticket?

Please explain to me exactly what is the issue.

Thanks,
Itamar.

April 8, 2019 at 10:28 am #3556633

Анна Ерохина

no problem!
When i installed a plugin and started to create pages in secondary languages i get this kind of error

This page isn’t working umpg.com.ua redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS

While trying to access the home page and other pages of my site at umpg.com.ua

April 8, 2019 at 10:29 am #3556639

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

What is the link to this page?

Could you please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

April 8, 2019 at 10:33 am #3556655

Анна Ерохина

--debug info removed by supporter--

April 8, 2019 at 10:51 am #3556827

Анна Ерохина

did you recieve debug info?

April 8, 2019 at 11:03 am #3556913

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for attaching the debug information.

By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if they help?

You are using the Satelite theme by Clapat.
This theme is not in our compatibility list here.
https://wpml.org/documentation/theme-compatibility/
Not being on this list does not mean that it is not compatible; it just means we do not know yet if it is. If the above procedure does not help, then please try to see if the problem persists when you switch the theme to a default WordPress like 2019.
Is it possible for you to try that?

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

April 8, 2019 at 11:09 am #3557007

Анна Ерохина

i tried the both steps you asked to try. and no luck. Can i give you an access to admin area to try to solve it by you?

April 8, 2019 at 11:12 am #3557025

Анна Ерохина

by the way - i already done full backup

April 8, 2019 at 11:38 am #3557271

Анна Ерохина

can i have an assistace?

April 8, 2019 at 11:55 am #3557357

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

FYI, this is a regular forum ticket and reply time might be longer.

Where can I see the of ERR_TOO_MANY_REDIRECTS on your site?

Please also try our full minimum environment procedure. Here are the details of how to proceed. I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated except WPML. You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

If the minimum environment procedure did not point to the problematic plugin or theme, please do the following:
Please provide me with the WordPress debug.log
Please check this page for instructions.
https://wpml.org/documentation/support/debugging-wpml/
Look under the headline "Enabling the built-in debugging feature in WordPress".
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);.

Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

Then please repeat the action that causes the ERR_TOO_MANY_REDIRECTS error. After this a log should be created in the wp-content folder. In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.
If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Please, could you provide me the additional Info?

Thanks,
Itamar.

April 8, 2019 at 12:12 pm #3557513

Анна Ерохина

i done everything like you asked, but i cant find this debug.log file on the server in a folder you pointed.

April 8, 2019 at 12:31 pm #3557657

Анна Ерохина

you can see this error while trying to access the adress hidden link

April 8, 2019 at 12:48 pm #3557821

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.